-   Linux - Software (
-   -   magic workstation0.94f instaler return access violation error Ubuntu9.10wine1.1.31 (

gnumaru 12-07-2009 10:00 AM

magic workstation0.94f instaler return access violation error Ubuntu9.10wine1.1.31
Magic Workstation is a Windows only program used to play "magic: the gathering" online.

I'm using Ubuntu 9.10 and wine 1.1.31

I tried to install the latest version o magic workstation (0.94f) using wine but the installer returns a window with the message "Access violation at address 0040C54A. Write of address 00400000." and a "OK" button that closes the installer. Running wine trough the terminal returns no error message, although.

Searching at to see if the program really works under wine, I found that it is gold rated on wine version 1.1.25 and above.
Searching other forums about magic, and about magic workstation, I founded no one with the same problems as me. I have, indeed, found some issues regarding the program itself, but none about installers not working. And with even deeper google research, I still haven't found no one with the same problem.

What I found was something regarding a known bug, which could somewhat be related to my problem,

But, even running wine as super-user, changing .wine owner to root and/or using the command workaround described there, I didn't managed to solve the problem.

What upsets me more is that as much as I search, it appears that no single person in the whole universe has the same problem.

I started thinking it was wine's problem, not magic workstation's problem. But I tried to run other installers under wine and they just seemed to be ok (I just launched the installers, not effectively installed the applications).

That's it. I just don't know what to do.
I there is some relevant info about my system that I should post, just tell me.

I Know there is a winedbg command, but I don't know exactly how it works, and if it would be able to help me.

And please, forgive for my english. I'm a portuguese speaker and I have never had english classes out of school, and the english classes of school where something like "verb to be" every year...

gnumaru 12-08-2009 09:48 AM

The installer is still not running, but I managed to find a workaround.

I installed magic workstation under Windows, copied the program folder from window's "Program Files" to wine's "Program Files".
Then, I used regedit on windows to export the registry entries on "HKCU/Software/Magic Workstation", and then imported the entries using wine's regedit.

Now, the program appear to run just fine, even though I haven't tested everything.

However, even if my main problem (running the app under wine) is solved, the question about the installer error is still unsolved.
And, if this problem is indeed new, it may (or may not) be some useful information for wine users and developers (so I'm going to post this on winehq forum too).

gnumaru 12-15-2009 03:40 AM

Recently, I tried to install Fedora 12, just for fun, and found that the magic workstation installer runs just fine on the wine version found in Fedora's repository (wich I don't remember wichh is, for I have already uninstalled it from my hard disk).
When I run the magic workstation installer, SElinux complains about unautorized memory acces or something, but it just doesn't prevents me at all from installing.
And, when I installed Ubuntu again on my hard disk, and installed wine 1.2 (wich does not realy "exists", since the last release is 1.1.34. I just know it's in the repos and I installed it.), I just haven't seen the problems I was experiencing earlier).
I just don't know what whas going on, but since no one had this problem, and It appear to be something so specific, and also because I am now able to run the installer, I just quit discussing about this subject.

If my english was not good, fogive me. I'm not an english speaker.

All times are GMT -5. The time now is 04:09 AM.