LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-12-2006, 06:50 AM   #1
sw67
Member
 
Registered: Oct 2004
Location: Here
Distribution: Slackware 12, openSuSE 11.0, XP
Posts: 76

Rep: Reputation: 15
Mach64 Direct Rendering with X.Org 6.8.2


I know it's an old card, but I'd like to get it to enable direct rendering on slackware 10.2 with X 6.8.2 and kernel 2.6.17.11.

I've built Mesa 6.4.2, and checked out the DRM CVS for mach64, and built it successfully - I can load drm and mach64 with modprobe, and it seems to work fine.
However, when I tell X to use it, it complains -
Code:
(EE) LoadModule: Module mach64 does not have a mach64ModuleData data object
(EE) Failed to load module "mach64" (invalid module, 0)
(EE) No drivers available.
Note that I copied mach64_drv.o into /usr/X11R6/lib/modules/drivers to allow X to find it.

I also tried building older versions of the mach64 drm, but they failed with an unrelated error (structure has no member named "count")

Any ideas? I've spent a fair few hours on this...

Last edited by sw67; 09-12-2006 at 06:51 AM.
 
Old 09-13-2006, 12:19 AM   #2
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 278
Blog Entries: 7

Rep: Reputation: Disabled
Don't waste your time, older rage (Mach64) wouldn't support DRI, unless you get rage pro and newer, and the later card needs renamed the driver r128, which can support DRI.

Last edited by number22; 09-13-2006 at 12:23 AM.
 
Old 11-08-2007, 09:20 AM   #3
simopal6
Member
 
Registered: Jun 2006
Location: Italy
Distribution: Slackware 13.1
Posts: 230

Rep: Reputation: 30
Quote:
Originally Posted by sw67 View Post
I've built Mesa 6.4.2, and checked out the DRM CVS for mach64, and built it successfully - I can load drm and mach64 with modprobe, and it seems to work fine.
Can you explain how you checked out mach64 sources?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Direct rendering not working after X.org packages update PCPbSlack Slackware 1 07-29-2006 06:00 AM
No direct rendering with DRI/DRM on X.org 6.8.2 Bariton Linux - Hardware 2 07-20-2006 05:50 AM
No Direct Rendering with Radeon 9700Pro in X.org 6.8.2 Dtsazza Linux - Software 12 12-01-2005 03:22 PM
mach64 dell inspiron 5000 no direct rendering Potatopopper Slackware 2 11-21-2005 01:43 PM
Direct rendering: please help! parmenide Linux - Hardware 1 07-13-2005 08:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration