LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-13-2003, 12:12 PM   #1
Robin01
Member
 
Registered: Aug 2003
Posts: 104

Rep: Reputation: 15
LZIB/apache installation issue --help


Hello everybody...

I cann't seem to compile apache with running into issues....and stuck for answers..
what i have:mandarke9.2/ openssl/apache2/ zlib1.1.4

apache configuration:
./configure --prefix=/wwwroot/apache2 --enable-mods-shared=most --enable-deflate --enable-ssl --with-z=/usr/lib --with-ssl=/usr/lib

make -->diplaying the messages:
----------------------------------------------------
2.0.48/modules/dav/main -prefer-pic -c mod_deflate.c && touch mod_deflate.slo
In file included from /usr/include/zutil.h:17,
from mod_deflate.c:79:
/usr/include/zlib.h:68: error: redefinition of `struct z_stream_s'
/usr/include/zlib.h:705: error: conflicting types for `gzwrite'
/usr/local/include/zlib.h:982: error: previous declaration of `gzwrite'
/usr/include/zlib.h:882: error: redefinition of `struct internal_state'
make[4]: *** [mod_deflate.slo] Error 1
make[4]: Leaving directory `/downloads/httpd-2.0.48/modules/filters'
make[3]: *** [shared-build-recursive] Error 1
make[3]: Leaving directory `/downloads/httpd-2.0.48/modules/filters'
make[2]: *** [shared-build-recursive] Error 1
make[2]: Leaving directory `/downloads/httpd-2.0.48/modules'
make[1]: *** [shared-build-recursive] Error 1
make[1]: Leaving directory `/downloads/httpd-2.0.48'
make: *** [all-recursive] Error 1
-----------------------------------------------------------------
any help would be greatly appreciated...
Lost for answers...
i followed the inst. from http://www.devside.net/web/server/linux/zlib
http://www.devside.net/web/server/linux/zlib
 
Old 02-05-2004, 01:08 PM   #2
mdkelly069
Member
 
Registered: Oct 2003
Posts: 43

Rep: Reputation: 15
Same problem

I know this post is a little old, but I ran into the same problem so rather than create a new post with exactly the same content I thought I would bump this one

^bump^

I hope someone, or the original poster has solved this.

Thanks for any and all help

mdkelly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp/apache issue Odins_Son Linux - General 1 08-17-2005 06:29 AM
Apache Issue Jukas Linux - Software 3 07-14-2005 02:33 PM
Is this an apache issue? opsraja Linux - Networking 1 03-03-2005 12:03 AM
differences between Apache 2.0.47 in comparison to Apache 1.3.28 installation? rohanrohanrohan Linux - Newbie 2 11-06-2003 02:22 AM
apache issue... Robin01 Linux - Newbie 3 09-21-2003 07:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration