-   Linux - Software (
-   -   LVM snapshot creation error (

haertig 01-30-2006 09:19 PM

LVM snapshot creation error
I'm seeing the error below when creating an LVM2 snapshot. Has anyone run into something similar and have a clue what's going on?

# lvcreate --snapshot --size 1Gb --name sss /dev/vg0/debian_home
LV vg0/sss in use: not removing
Couldn't deactivate new snapshot.

I initially created the snapshot then immediately removed it and tried to recreate it again. I can't remember if I saw the error the FIRST time I ever created this snapshot. But I see it every time I try lvcreate now. I ran "modprobe dm-snapshot" before every trying to create the first snapshot. I did this because I had found earlier in the day, on a different Debian Sarge box, that the modprobe was required before snapshots would work. The Sarge box did not experience the error that I'm seeing with Sid.

After the above lvcreate, lvdisplay lists the /dev/vg0/sss LV, but with a line "#open 0". All other LV's have "#open 1"

/var/log/syslog has this error, triggered by the lvcreate (where xxxx are digits):[xxxx]: DEVNAME is not set

lvremove /dev/vg0/sss appears to work without error. After running lvremove, lvdisplay no longer shows the /dev/vg0/sss LV.

Debian SID
kernel 2.6.14-1-686
lvm2 2.01.14-3
lvm-common 1.5.20
libdevmapper1.01 2:1.01.05-1

haertig 01-30-2006 10:14 PM

Is this possibly a timing issue ???
Some additional info on my problem:

I walked away for 30 minutes, came back and tried the lvcreate again. IT WORKED!

So I ran the lvremove, then tried the lvcreate immediately after that. IT FAILED AGAIN.

So this appears to be some kind of timing thing. If I wait long enough after the lvremove before re-trying lvcreate, things work. It could be my previous report about not seeing problems in Sarge might be wrong (I'll have to check tomorrow). I only did lvcreate/lvremove once on Sarge and it appears to be the second and subsequent lvcreates that generate the error on Sid (until whatever times out, times out, and things get reset!)

Now I'm really confused! :confused:

All times are GMT -5. The time now is 04:43 PM.