-   Linux - Software (
-   -   LVM: IDE + SATA not possible? (

cabe 11-22-2006 03:17 AM

LVM: IDE + SATA not possible?
I have an 80G drive in an old computer running Debian Sarge (have used both 2.6.8 and 2.6.12 kernel) that acts as a samba server. Recently I upgraded the server with two 250G sata drives and a Sil3114 based SYBA sata controller card. When mounted by themselves, the 250G drives work fine with no problems.

The problem is when I try to add the drives to my current logical volume. I can add the drives to the volume group, extend the volume, and extend the file system -- but when I reboot the UUID of the drives must change! I also tried copying a bunch of files over to the logical volume and got corruption.

Upon executing a lvs/lvscan/vgs/vgscan command I get...


debian:~# vgs --partial
  Partial mode. Incomplete volume groups will be activated read-only.
  Couldn't find device with uuid 'J5xCCr-mFyg-yzBp-2v3j-75vO-s4Al-kQdzHq'.
  Couldn't find device with uuid '4JquQL-Vo7R-HotY-Vh76-lewb-B7A8-2csjQw'.
  VG  #PV #LV #SN Attr  VSize  VFree
  stor  3  1  0 rz-pn 528.35G 360.00M

So why would the drives work on their own but not with LVM? Makes me feel like LVM is to blame, but it's working fine with the 80G IDE-connected drive.

Soo.. what gives!?

I now also have the problem of not being able to access any data stored within the LV on the 80G drive..

Any suggestions/comments/thoughtless ramblings both welcome and greatly encouraged!



cabe 11-22-2006 07:33 PM


Anyone have any ideas? :scratch:

cybertaz 11-23-2006 03:27 AM

I have both IDE and SATA. The motherboard does native support. Might it a card driver problem and not LVM?

cabe 11-23-2006 12:12 PM

I originally did think that was the problem until I tried formatting the drives to ext3 and mounting them individually. Samba file transferes worked fine with no corruption, but when I tried to add the drives back to the logical volume I had the same problems all over again!

makyo 11-24-2006 12:44 PM

Hi, cabe.

One of my servers has a mixed SATA and IDE group.

However, there are many differences. The box is a Dell and I removed the mainboard "RAID" setting (as advised by Dell support). The LVM is controlling 2 SATA and 1 IDE in a RAID-0. This was defined at installation of RedHat, not added later.

So all I can say is that for this one instance, LVM has handled SATA + IDE OK for me.

Sorry I cannot be of more help; best wishes ... cheers, makyo

cabe 11-25-2006 09:39 AM

To further confuse things, I've tried putting the sata drives in their own volume group, and everything works fine! It just seems that they don't like to be grouped with the pata drive.. very weird..

All times are GMT -5. The time now is 10:29 AM.