LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-25-2011, 04:36 PM   #1
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
lsattr: Inappropriate ioctl for device While reading flags


For one of our servers, if I do lsattr /home, I get something like this (as root):
Code:
 
$lsattr /home
lsattr: Inappropriate ioctl for device While reading flags on /home/user
lsattr: Inappropriate ioctl for device While reading flags on /home/user
lsattr: Inappropriate ioctl for device While reading flags on /home/DIR
Now, I try to change something with chattr
Code:
$chattr -R -i /home
chattr: Inappropriate ioctl for device while reading flags on /home
Mount returns:
Code:
$mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda3 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
I have no clue how to fix this. Could somebody help?
 
Old 10-26-2011, 04:13 PM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 7
Posts: 3,496

Rep: Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933Reputation: 933
what is printed by:
Code:
ls -lZ /home
 
Old 10-26-2011, 04:15 PM   #3
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Original Poster
Rep: Reputation: 48
I have turned off Selinux on this computer. So the issue of Selinux should not arise.
Thanks
 
Old 10-27-2011, 10:12 AM   #4
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Original Poster
Rep: Reputation: 48
Fixed. cat /proc/mounts returned automount in /home/DIR where I had initially set users to login automatically for LDAP logins. I removed the option later on- and restarted autofs. But somehow it still was on /proc/mounts. That's why lsattr was not working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error no 25: Inappropriate ioctl for device for RTC cruiser Linux - Software 1 10-17-2011 12:13 AM
Inappropriate ioctl for device while reading flags w1k0 Slackware 3 06-01-2009 08:45 PM
Inappropriate ioctl for device with perl Punakuono Linux - Newbie 3 05-15-2009 03:05 AM
inappropriate ioctl for device praetorrian Linux - Software 1 05-09-2006 01:11 AM
Inappropriate ioctl for device(25) why1957 Linux - Networking 0 08-03-2003 05:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration