LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-07-2009, 12:27 AM   #1
Nemesissparadise
Member
 
Registered: Nov 2007
Location: North Pole Alaska
Distribution: Fedora
Posts: 137

Rep: Reputation: 15
low volume and wont send sound to headphones


i am running fedora i think 10? latest stable release.My sound is barely audible and it wont send sound to my headphone jacks.

Yes i have checked my volume is set to max on both the audio mixer and the volume control on the front of my Toshiba satellite a135 laptop.
 
Old 10-07-2009, 05:53 AM   #2
just1newbie
Member
 
Registered: Jul 2009
Location: romania,iasi
Distribution: slackware 13.0
Posts: 46

Rep: Reputation: 15
type in terminal alsamixer and rise the level on sound.use the"M" key to unlock the locked option if you need .
 
Old 10-07-2009, 07:51 PM   #3
Nemesissparadise
Member
 
Registered: Nov 2007
Location: North Pole Alaska
Distribution: Fedora
Posts: 137

Original Poster
Rep: Reputation: 15
ok thanks that worked however when i restart my computer i have do that again is there a way to have it stay that way?
 
Old 10-08-2009, 08:50 AM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
# alsactl store 0

# alsactl restore 0
(if it doesn't for some reason)

There's several mixer applications and your distro might not default to alsa if another is present with saved values. Like aumix. AFAIK, the results are saved to /etc/asound.state. So if you want it to default to another mixer, you might just have to delete that file. Or however your distro / your system is setup.
 
Old 10-08-2009, 08:50 AM   #5
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
...

Last edited by Shadow_7; 10-08-2009 at 08:54 AM. Reason: duplicate post
 
Old 10-08-2009, 12:29 PM   #6
Nemesissparadise
Member
 
Registered: Nov 2007
Location: North Pole Alaska
Distribution: Fedora
Posts: 137

Original Poster
Rep: Reputation: 15
ok thanks to you both. Now my other issue with the sound not being switch to the headphones does anybody have any ideas?
 
Old 10-08-2009, 05:18 PM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
define switch.

Some devices are wired that when you plug in the headphones, the speakers no longer output sound. Some are not and each is their own thing and otherwise always on at whatever levels you've set. So what behavior, or lack there of are you expecting. And what specific hardware is in question(soundcard).
 
Old 10-08-2009, 11:37 PM   #8
Nemesissparadise
Member
 
Registered: Nov 2007
Location: North Pole Alaska
Distribution: Fedora
Posts: 137

Original Poster
Rep: Reputation: 15
ok i unnderstand what you are saying however im unsure how to awnser it i now have sound that is audible and im happy with it however when i plug in my headphones into the jack (laptop) it iget no sound from them it stil sends it to the speakers
 
Old 10-09-2009, 12:29 AM   #9
just1newbie
Member
 
Registered: Jul 2009
Location: romania,iasi
Distribution: slackware 13.0
Posts: 46

Rep: Reputation: 15
see if alsa it's your audio controller .try to play whit the rest of the option.if you dont have luck ,try to update alsa(see on forum how).
 
Old 10-09-2009, 06:37 AM   #10
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
$ alsamixer -c 0

Some laptops have an extra headphone only channel. Dells are known for this. And this mixer setting may only be available in alsamixer. F1 for help, but mostly cursor keys, "M" for mute/unmute, and ESC to exit.

$ cat /proc/asound/cards

$ amixer

Those should give you/us more detail on what / where / when / who done it. Either pipe it to a file " > file.txt" or " 2>&1 file.txt" or use tee to read and pipe " | tee file.txt". Or just read it as is. Shift+PgUp scrolls up in a term / console / cli / jargon of the week.
 
Old 10-09-2009, 01:06 PM   #11
Nemesissparadise
Member
 
Registered: Nov 2007
Location: North Pole Alaska
Distribution: Fedora
Posts: 137

Original Poster
Rep: Reputation: 15
ok i used those tocommands and this is what i recieved for output I am to much of a newbie to us much of this information
o and it a Toshiba satellite a135

[nemesis@nemesis-laptop ~]$ alsamoxer -c0
bash: alsamoxer: command not found
[nemesis@nemesis-laptop ~]$ alsamixer -c0
[nemesis@nemesis-laptop ~]$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xdc440000 irq 22
[nemesis@nemesis-laptop ~]$ amixer
Simple mixer control 'Master',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Mono:
Front Left: Playback 65536 [100%] [on]
Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 65536 [100%] [on]
Front Right: Capture 65536 [100%] [on]
[nemesis@nemesis-laptop ~]$

Last edited by Nemesissparadise; 10-09-2009 at 01:08 PM. Reason: name laptop
 
Old 10-10-2009, 04:23 PM   #12
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Quote:
Originally Posted by Nemesissparadise View Post
[nemesis@nemesis-laptop ~]$ alsamoxer -c0
bash: alsamoxer: command not found
That could be a problem. It appears that you don' have a portion of alsa installed. Or access to that portion. Is the user in the sound group? Did you install alsa-utils and/or alsa-tools? Your distro might have put them in separate packages.

Quote:
Originally Posted by Nemesissparadise View Post
0 [Intel ]: HDA-Intel - HDA Intel
That's a common card. Although drivers for it are still a bit beta IMO. Or at least was a year or more back. I've got a different card so I haven't really used that one much. In either case, you appear to not have everything that you need installed on your system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound volume BECAME low Rimio Linux - Hardware 3 09-01-2008 10:06 PM
Low volume in headphones ddna Linux - Hardware 1 09-27-2007 07:19 PM
very low sound with headphones none with spekers ___ kmixer problem? polzbert Linux - Software 2 09-27-2004 05:24 AM
Sound volume very low stocks29 Linux - General 6 09-24-2004 01:44 PM
sound volume very low jkilbourne Linux - Newbie 1 01-07-2002 11:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration