-   Linux - Software (
-   -   lots of quick questions, help please (kernel, installing stuff, etc) (

ixp 12-29-2003 07:25 PM

lots of quick questions, help please (kernel, installing stuff, etc)
im a newbie at this =p

i installed mandrake 9.2 the other day, dual booting with win2k3, works fine, LILO works, etc. sound is however, too soft/low, and i dont know how to increase it. sound is based off an ac'97 codec from the kt133 chipset line. its sooo soft =\.

how do i update the 2.4 kernel to 2.6? without all that command line stuff, or is that the only way.

i tried to update java, but it ends in -rpm.bin, so i dont know what to do?

how do i update kde to 3.1.4? i downloaded the..source? i think, should i have gotten the rpms instead and just upgrade it?

how do i install stuff? cause i have no idea =\

dunno command line commands either, ahhh

darin3200 12-29-2003 08:01 PM

1.try "kmixer" and see if you can raise the volume
2.Unless something doesn't work you really don't need to upgrade your kernel, learn to install programs first.
3. To install java just type
sh file-name-of-java.rpm.bin
this is get you the java rpm, I will address how to install programs at the end of this post
4.Again, 9.2 is pretty recent, unless there is a new feature you need I wouldn't bother replacing KDE, it would take a lot of time and effort.
5. From source code read this
Also use mandrake package managment tools under configuration.
For rpms, to install type
rpm -ivh filename
as root i=install v=verbose h=hash, or progress bar

Also on the learning commands

ixp 12-29-2003 08:25 PM

oh and another question, does the 2.4 kernel support dynamic ntfs drives? cause it can't read mine =|
and how do i get command lines for java to work? i installed it, though none of the commands work?

darin3200 12-29-2003 10:09 PM

I'm not sure what an dynamic ntfs drive is, what have you done to try to read it? About the jave, first you need to find where you java programs are located. Start by going into /usr/java and find the next directory that java would be in. After you have gone into that there should be a bin file. Now your's might be different, but the path to my bin is
/usr/java/j2sdk1.4.2/bin or you can find it with "locate java"
Now type
export PATH=$PATH:/usr/java/j2sdk1.4.2/bin (with your own path to bin) and see if you can access the commands.

ixp 12-29-2003 10:22 PM

oh, a dynamic ntfs drive has simple volumes spanned volumes striped volumes mirrored volumes RAID-5 volumes or something like that, im guessing software raid? or something to that extent?

darin3200 12-29-2003 11:13 PM

have you tried mounting those partitions yet?

ixp 12-29-2003 11:29 PM

oh, it does mount, but gives me a blank drive, it reads the other drive, the basic ntfs one

ixp 12-30-2003 03:44 PM

mm the java export doesnt work

darin3200 12-30-2003 04:15 PM

I'm afraid I know little about raid, sorry. But I think I know how to fix the java problem. As root go and open your /etc/profile. Here is mine from mandrake 9.2 set up for java

# /etc/profile -*- Mode: shell-script -*-
# (c) MandrakeSoft, Chmouel Boudjnah <>

# Users generally won't see annoyng core files
[ "$UID" = "0" ] && ulimit -S -c 1000000 > /dev/null 2>&1

if ! echo ${PATH} |grep -q /usr/X11R6/bin ; then

if [ "$UID" -ge 500 ] && ! echo ${PATH} |grep -q /usr/games ; then
    export PATH=$PATH:/usr/games

umask 022

USER=`id -un`

if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]; then

# some old programs still use it (eg: "man"), and it is also
# required for level1 compliance for LI18NUX2000


for i in /etc/profile.d/*.sh ; do
        if [ -x $i ]; then
                . $i

unset i

As you can see in the red I added that line with the path to the java programs.

ixp 12-30-2003 08:42 PM

woohoo java works now =) soo fast running the bluej ide compared to using it on windows
another quick question, open office..doesn't load? the splash screen only loads half way, and then nothing shows up, running open office 1.1

darin3200 12-30-2003 09:14 PM

Have you tried starting open office and given it a while. Sometimes it takes very long to load the first time.

All times are GMT -5. The time now is 05:31 PM.