-   Linux - Software (
-   -   Logical Volume recovery (

plythgam 03-27-2006 02:32 PM

Logical Volume recovery
I have a hard drive that was duel booted with windows and fedora. On the fedora I had a rootVG with several logical volumes. While trying something I screwed up the disk and neither partition will boot. I slaved the drive into another computer to get the data I needed off the windows and fedora partitions but I can't figure out how to mount the volume group in fedora without destroying the data.

I can see the partition with "fdisk /dev/sdb" and printing the partition info.

I tried to just mount it.

mount -t ext3 /media/usbdrive /dev/sdb5

but this says I am using the wrong filesystem type. I also tried the following.

fedora logical volume manager to see if it would see the slaved in volume group but since I couldn't mount the partition I couldn't see anything.

lvscan. I see the 4 logical volumes but they are all displayed as "inactive".

vgscan. I see the rootvg as well.

This is slaved into a machine that I don't use logical volumes on so there is not any conflicts with existing volumes.

Does anyone know how to mount the root volume group and the logical volumes to get the data off?

haertig 03-27-2006 02:59 PM

It would be nice to see what your "fdisk -l" output shows. Otherwise I'm just guessing here. I don't know what /dev/sdb5 is. I'm assuming that's your LVM physical volume. You don't mount this directly if this is indeed the case. You mount the logical volumes contained within /dev/sdb5 (which is a physical volume, part of a volume group, which contains logical volumes - or so I'm assuming).

It sounds like you removed the disk from it's original machine and now have it installed on a second machine. Correct? That second machine will need to have the LVM software installed, if it doesn't already. Now, on that second machine, run "vgscan" and then "vgchange -a y". Then run "ls /dev/mapper" and see what shows up. Hopefully your logical volumes will. You should then be able to mount them. Something like the example below:

$ su
# vgscan
# vgchange -a y
# ls /dev/mapper
( this should should list things like /dev/mapper/XXX-YYY )
# mkdir /mnt/tmp
# mount /dev/XXX/YYY /mnt/tmp
# ls /mnt/tmp

From your description, it sounds like you're probably only missing the "vgchange -a y" part. The rest I included only for completeness.

plythgam 03-27-2006 06:44 PM

Thanks haertig. After entering the vgchange -a y and rescanning for logical volumes they all said active. I created directories in the /tmp and mounted them. I got all the data off with no problems. Thanks again.

All times are GMT -5. The time now is 12:05 PM.