LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-11-2017, 08:43 AM   #1
poonippi
Member
 
Registered: Dec 2007
Distribution: Debain Fluxbox
Posts: 76

Rep: Reputation: 15
lm-sensors setting thresholds


Hi,
I have a server with the following sensors output:

Code:
intel5500-pci-00a3
Adapter: PCI adapter
Chipset:        +40.5C  (high = +95.0C, hyst = +90.0C)  ALARM (HIGH)
                       (crit = +110.0C)
As you can see, it's trigger and ALARM, but 40C really shouldn't be a problem. This is creating false-positives on my monitoring.

I created the following custom sensors mapping:
Code:
##intel5500-pci-00a3
##Adapter: PCI adapter
##temp1:
##  temp1_input: 40.000
##  temp1_max: 95.000
##  temp1_max_hyst: 90.000
##  temp1_crit: 110.000
##  temp1_max_alarm: 2.000
##  temp1_crit_alarm: 0.000

chip "intel5500-pci-00a3"
	label temp1 "Chipset"
	set temp1_max 10.000
	set temp1_crit 95.000
Nothing appears to change the settings in brackets. Any ideas?
 
Old 05-11-2017, 01:43 PM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,393
Blog Entries: 10

Rep: Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212
Quote:
Originally Posted by poonippi View Post
Code:
intel5500-pci-00a3
Adapter: PCI adapter
so, that's not a cpu right?


Quote:
Code:
set temp1_max 10.000
10.000? shouldn't that be 100.00?
 
Old 05-12-2017, 04:05 AM   #3
poonippi
Member
 
Registered: Dec 2007
Distribution: Debain Fluxbox
Posts: 76

Original Poster
Rep: Reputation: 15
It's the Intel HD Graphics chipset, in any case I have a dedicated GPU.

I had previously tried higher numbers, like you suggest, no difference.
 
Old 05-12-2017, 11:06 PM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,393
Blog Entries: 10

Rep: Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212
Quote:
Originally Posted by poonippi View Post
I had previously tried higher numbers, like you suggest, no difference.
that's strange.
my vulcan logic tells me that if temp_max is set to 10 degrees (which is really fridge temperature), 40 degrees will certainly trigger an alarm.
 
Old 05-13-2017, 06:05 PM   #5
poonippi
Member
 
Registered: Dec 2007
Distribution: Debain Fluxbox
Posts: 76

Original Poster
Rep: Reputation: 15
OK - but regardless what I set it to, it still alarms, and none of the high, hyst, etc can be changed:

set temp1_max 50.00

Chipset: +40.0C (high = +95.0C, hyst = +90.0C) ALARM (HIGH)
 
Old 05-14-2017, 01:11 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,393
Blog Entries: 10

Rep: Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212
maybe you need to restart the daemon or something for changes to take effect.
 
Old 05-14-2017, 08:41 AM   #7
poonippi
Member
 
Registered: Dec 2007
Distribution: Debain Fluxbox
Posts: 76

Original Poster
Rep: Reputation: 15
There is no daemon, it's a single-shot binary, that only runs when you ask it and simply prints the output.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Thinkpad R500 thermal sensors names (lm-sensors) flyingv2 Linux - Laptop and Netbook 1 09-30-2013 12:49 AM
Thresholds jorran Linux - Newbie 4 01-04-2012 01:51 PM
sensors-detect not detecting sensors on my dell laptop (XPS L401X) themande Linux - Newbie 1 10-20-2011 04:07 PM
setting sensors for Asus P5PL2-E and Intel Pentium D 3.2GHz Mr. Bond Slackware 3 01-20-2008 06:39 AM
CPU Temperature thresholds. liguorir Solaris / OpenSolaris 1 10-15-2004 10:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration