LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-25-2017, 09:37 AM   #1
kev717
Member
 
Registered: May 2008
Distribution: Arch, FreeBSD
Posts: 103

Rep: Reputation: 17
LIRC audio input with pulseaudio?


I haven't found anything recent on setting up LIRC using an audio receiver. I want to try setting up something for IR Control using audio input with PulseAudio, but there doesn't appear to be anything available.

I have alsa utils installed, so using audio_alsa *should* work, but it doesn't. I get an error regardless of what device I set. Just trying to run `irrecord -d pulse@44100,r` or `irrecord -d default@44100,r` or `irrecord -d hw:0@44100,r` yields "Could not init hardware" error.

If I disable pulseaudio entirely, it looks like it's going to work, but when I run irrecord it says "Checking for ambient light creating too much disturbances. Please don't press any buttons, just wait a few seconds..." regardless of whether there's any input to the audio card.

Output from arecord -L:

Code:
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=SB
    HDA ATI SB, VT1708S Analog
    Default Audio Device
front:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    Front speakers
Is there any way to get LIRC to work with audio input on a modern Linux system?

Last edited by kev717; 11-25-2017 at 09:53 AM. Reason: more details
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 14.2: No Microphone Input with PulseAudio Sylvester Ink Slackware 9 07-15-2016 11:40 PM
Lirc works, but XBMC does not respond to Infrared input fmr Linux - Software 5 04-15-2013 03:42 PM
[SOLVED] Installed LIRC-0.9.0 on Fedora 14, /dev/lirc was not created, lirc programs won't run FalkiD Linux - Software 4 06-06-2011 10:33 AM
smplayer: video+audio stutters with pulseaudio, audio files play fine GamerX Linux - Desktop 1 02-06-2009 09:53 PM
Odd behaviour from LIRC /dev/input Akdor 1154 Linux - Software 0 03-04-2008 05:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration