-   Linux - Software (
-   -   LIRC 0.80 compilation issues (

thugic 08-13-2006 09:54 AM

LIRC 0.80 compilation issues
I have a nice USB RF Remote Receiver and its Controller made by X10.
I haven't ever tried to install it nor to make it work with Linux but in the last days I have some spare time thus I'm doing my best to use my box without a keyboard and eventually without a mouse.
Now, I read some tutorials and compiled the ati_remote and ati_remote2 into the kernel; after that I ran xev and started randomly pressing buttons on the remote: "bingo! It was showing the keycodes!"!
Well, now I knew the system was receiving the radio signals sent by the remote control but a new problem came in: how to make it interact with the box?
At first I thought I could use Lineakd thing but when I installed it I didn't know how to manage to get it work, the only instructions I found were written in German (ps: anyone from Germany that can translate that page for me? ;) ), then I thought of Lirc and its KDE's implementation called "Lirc Server", that would have allowed me to to almost everything in few and simple steps!
But, when I started compiling Lirc-0.80 it gave me an error:

/home/thug/Desktop/lirc-0.8.0/drivers/lirc_atiusb/lirc_atiusb.c:1183: error: unknown field `owner' specified in initializer
/home/thug/Desktop/lirc-0.8.0/drivers/lirc_atiusb/lirc_atiusb.c:1183: warning: initialization from incompatible pointer type
make[5]: *** [/home/thug/Desktop/lirc-0.8.0/drivers/lirc_atiusb/lirc_atiusb.o] Error 1
make[4]: *** [_module_/home/thug/Desktop/lirc-0.8.0/drivers/lirc_atiusb] Error 2
make[4]: Leaving directory `/usr/src/linux-'
make[3]: *** [lirc_atiusb.o] Error 2
make[3]: Leaving directory `/home/thug/Desktop/lirc-0.8.0/drivers/lirc_atiusb'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/thug/Desktop/lirc-0.8.0/drivers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/thug/Desktop/lirc-0.8.0'
make: *** [all] Error 2

so I couldn't go on with the installation...
Is there any way to fix this error? I tried also to install a previuos version but it didn't work.
Any idea about how to get Lirc working or to get my remote operative under Linux?
(I'm using Slackware 10.2, KDE 3.5.2, Kernel-, a lot of coffee :))

cdhgee 08-15-2006 03:20 AM

I can't advise you much about making your remote interact with your box, but you won't make it work with LIRC. LIRC is Linux Infra-Red Controller - which as its name implies is intended for IR devices only. Even if you were to get it to compile, it wouldn't work with your hardware.

thugic 08-15-2006 03:23 AM

Actually, if I knew it wuold not work with LIRC I would't have started compiling it! :)
I read that it is now supporting the ati_remote RF remotes so I guess that's my case ...
Dunnow, perhaps I gotta post this thread in Slackware forum also, as it seems to be strictly Slackware-related, not a LIRC issue...
Thanks anyway ;)

cdhgee 08-15-2006 03:25 AM

If that's the case, my bad, apologies. I don't know much about Slackware but can you obtain pre-compiled binaries for it? For Fedora (which I use), there are pre-compiled packages for the software and the kernel modules available in public repositories, perhaps this is also the case for Slackware...

thugic 08-15-2006 03:28 AM

That's a nice idea, but the only package I have found is a previous version of the current one, it was the 0.70 package, and it wasn't compiled with the "drivers" I need. The problem is that the website isn't so clear about this compiling issues, and doesn't have any forum so support is a bit difficult.

All times are GMT -5. The time now is 03:14 AM.