LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Linux won't boot up (https://www.linuxquestions.org/questions/linux-software-2/linux-wont-boot-up-4175418839/)

aspireone 07-26-2012 04:21 PM

Linux won't boot up
 
Hi guys, can anyone help?

Acer Aspire One running Linux has suddendly stopped booting up with the following message:

Failed to start message bus: failed to bind socket "/var/run/dbus/system_bus_socket": Address already in use
sudo:sudo please use single character optionsplease
sudo:sudo no passwd entry for linpus
FATAL: Module speedstep_lib not found
Starting acpi daemon:acpid:starting up
OK
acpid: 1 rule loaded
setpci: Warning: No devices selected for AE47
/etc/rc.d/rc.last.ctrl:line 17 /sys/bus/usb/devices/5-5/power/level:No such file or directory

All of which means nothing to me but the thing ain't working! Any help would be greatly appreciated

John VV 07-26-2012 04:35 PM

what did you last do?
install some program ?

also WHAT operating system is this ?
this is an acer netbook so i am guessing "limpus light"
that is about 5 years out of date and was loosely based on the very OLD fedora 8 ( from 5 years ago)

aspireone 07-26-2012 04:45 PM

Hi John

Thanks for the quick reply, yes it is a netbook, two years old. Think it is limpus lite.

Only ever used for surfing the web. Nothing installed recently, shut down as normal last night, won't boot this morning.

Any ideas what's up?

John VV 07-27-2012 12:57 AM

can you boot into single user mode or text only
( think of it as "safe mode" on Windows)
during the 3 sec. count down at the very beginning of booting
hit < enter>
then < e> for edit

use the down arrow to move to the boot line and a the number 1 to the end

a space then 1 or a 3 for text boot
then hit <b> for boot
if so then read the boor log file for the error
/var/log
the boot.0.log and xorg.log and messages

in those 3 files will be the error

aspireone 07-27-2012 03:06 PM

Have tried to boot into single user mode as you suggested but nothing happens just get the blue aspire one screen same as before?

Thanks

John VV 07-27-2012 04:00 PM

without knowing what the logs say ... i can only guess


things like the ram becoming unseated can cause it to error
or some of the ram has gone bad
or
some of the hardware became disconnected or has gone bad

there is no dvd drive
so if you "can" boot using a live USB image ?
then you can read the logs

aspireone 07-27-2012 05:27 PM

Worth a try but I don't know how to do that, can you advise?

Linux_420 07-28-2012 09:31 PM

ram / harddrive not being seated properly can cause something of the sort... try to boot from a live distro and access your hard drive to ensure that it is seated (or just open the laptop, remove the hard drive/ram, then reseat the hard drive/ram).

Karl Godt 07-28-2012 09:53 PM

I think you had a hard poweroff and dbus was not able to delete the file /var/run/dbus/system_bus_socket .

Code:

find /var -name dbus -exec ls -R {} \;
gives me

/var/lib/dbus:
machine-id

/var/run/dbus:
pid system_bus_socket

The existing pid file might be the main problem .

You should organize some USB Pendrive bootable linux, boot it, mount the main partition, navigate to the /var directory and delete the dbus files (not the directories) .

[Another thing is ownership and permissions of the dbus files/directories.]

dbus itself on Puppy Linux for example gets launched by /etc/init.d/01_messagebus script .

*

Nevertheless your system boots, but refuses to launch the desktop/windowmanager .

The "blue screen" must be some sort of "/bin/whiptail" or "/bin/dialog" started by a script.

aspireone 07-29-2012 07:28 AM

Ok thanks,think I understand. Can you suggest a site or program for the USB bootable linux?

EDDY1 07-29-2012 01:33 PM

Quote:

Originally Posted by aspireone (Post 4740492)
Ok thanks,think I understand. Can you suggest a site or program for the USB bootable linux?

Unetbootin will prepare your usb drive for any live distro
http://unetbootin.sourceforge.net/
What version are you using?
http://distrowatch.com/table.php?distribution=linpus

Karl Godt 07-29-2012 03:06 PM

Quote:

Originally Posted by aspireone (Post 4740492)
Ok thanks,think I understand. Can you suggest a site or program for the USB bootable linux?

Puppy Linux.

Linux is not for beginners.
Especially Puppy Linux because it lacks the manpages, which are accessible via the internet though.

I was a beginner once.

aspireone 07-29-2012 03:48 PM

Hey guys I've fixed it!

Followed your advice and booted with linuxliveusb.com

Have upgraded to Ubuntu, working perfectly.

Thank you, one and all

Best regards

Gary

EDDY1 07-29-2012 11:09 PM

Congrats aspireone!


All times are GMT -5. The time now is 02:17 PM.