LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Linux vs. Windows DVD predicament (ogle/alsa) (https://www.linuxquestions.org/questions/linux-software-2/linux-vs-windows-dvd-predicament-ogle-alsa-87324/)

Nimoy 08-30-2003 10:36 AM

Linux vs. Windows DVD predicament (ogle/alsa)
 
Okay here is my predicament!

I am helping a friend to migrate to linux. I have managed to get graphics (NVidia Geforce 5200) and sound (SB Live 5.1) up on his system.

It is possible to play back CD's via the ALSA player so I think the sound system should be OK to handle the Ogle ALSA requirements.


However as soon as I try playing back DVD's the following happens.


The DVD splash screen opens (so there is picture) but when I then choose which language the CD is to run in OGLE decides I have seen enough :-(


I checked out the ogle FAQ to see if anyone had encountered similar problems but have been unable to see any similar case.

I have tried to implement the following suggested changes in the oglerc file in usr/local/shared/ogle, as this was the only sound related piece I could find.


FROM FAQ: (43)
# Change the Alsa device name from 'default' to 'iec958' in the oglerc. (the SP/DIF device migth not be named iec958, you'll have to find out).

<alsa>
<name>iec958</name>
</alsa>

Some cards require additional parameters to do SP/DIF output. You migh have to use a device like the following.

<alsa>
<name>iec958:AES0=0x2,AES1=0x82,AES2=0x0,AES3=0x2</name>
</alsa>



I tried both these with no result


The FAQ mentions I should: # Use a mixer app to enable the iec958 output. For example the Gnome-ALSA Mixer.


Well the GNOME-ALSA mixer won't work, neither from a TAR nor from RPM, any suggestion on how the ouput could be enabled, if indeed this is what I need?

BTW: The ALSA GNOME Mixer both installs and runs - but is after that unable to present me with anything but an empty window... If I choose properties the following error displays:

Application "gnome-alsamixer" (process 7029) has crashed
due to a fatal error.
(Segmentation fault)

And preferences opens a tiny window titled Application Pre... with a button giving me the option to close the window.



The FAQ also mentions the following about the channels:

# Change the channel_configs in the oglerc so the wanted audio types are used.

<speakers>
<channel_config>
<chtype>AC3</chtype>
</channel_config>
<channel_config>
<chtype>DTS</chtype>
</channel_config>
<channel_config>
<chtype>MPEG</chtype>
</channel_config>
<channel_config>
<chtype>LPCM</chtype>
</channel_config>
</speakers>

These are the types of audio that can be sent over SP/DIF, add/keep those that you want and you amplifier can handle. Most amplifiers only do AC3 and LPCM, DTS and MPEG are a bit more uncommon.



??? How do I enable / disable these types of sound - Using the # ???


How can I determine what audio types are relevant... ?



I would have handed the system to my friend with the option to play DVD's in Windows 98 (dual boot) as sound works fine there. (He has some old 98 progs. he wants to use)

However graphics won't work as the NVidia drivers have utterly refused to install... funny thing is that the reverse seems to be true for Linux.

Graphics OK but no sound... well no sound for OGLE that is.


I suspect that if I could locate the ALSA driver I would be in the clear by putting it into the oglerc configuration file however I don't know how to find the ALSA directory where the driver ought to be.


I am including the command line output below - If anyone has any suggestions on how to get this thing on the road let me know.

I need this system out of my life pronto!!!

I have been struggling to get it up and running for more than a week... I have not yet given up yet but must admit I've been close to recommending my friend to get and install XP ... but what kind of friendly gesture would that be with all the security problems that seem to be around these days???

I am trying to stay true to the credo: "Never give up! Never surrender!" - But it is very hard....

All that aside here is the command line output:

[topp@localhost topp]$ ogle
libdvdread: Using libdvdcss version 1.2.7 for DVD access
libdvdread: Attempting to use device /dev/cdrom mounted on /mnt/cdrom for CSS authentication
libdvdread: Using libdvdcss version 1.2.7 for DVD access
libdvdread: Attempting to use device /dev/cdrom mounted on /mnt/cdrom for CSS authentication

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000139
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x0000a3d8
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x0001f82c
libdvdread: Elapsed time 0
libdvdread: Found 1 VTS's
libdvdread: Elapsed time 0
!!No accelerated IMDCT transform found
ERROR[ogle_audio]: Opening alsa pcm device 'default': No such file or directory
FATAL[ogle_audio]: failed opening the alsa audio driver at default
ctrl: ipc_rmid: Invalid argument

Nimoy 08-31-2003 08:30 AM

What??? No brilliant suggestions? - MAYDAY!!!

acid_kewpie 08-31-2003 08:40 AM

don't use Ogle.... http://mplayerhq.hu

as for audio there though, it just says you don't have an alsa service running. do you have a /dev/dsp?

Nimoy 08-31-2003 09:48 AM

No luck...
 
No no /dev/dsp as far as I can see.

MPlayer - tried it on two systems, compiles alright but behaves just like Ogle... only Ogle manages to get images onto the screen... So if the sound will work I'll settle for that! Even though I do understand MPlayer has a lot more features to offer...

Nimoy 08-31-2003 09:49 AM

BTW any recommendations on the /dev/dsp issue???

acid_kewpie 08-31-2003 09:56 AM

well alsa should start as a service - /etc/init.d/alsasound start

i suck at troubel shooting alsa though, lots of issues with it myself.

Nimoy 08-31-2003 02:08 PM

Well ogle keeps giving me the same old... tried to reinstall MPlayer as well still no luck - Wish someone knew what to tell Ogle.

But alsasound is definitely located in /etc/init.d

grrrr - this is driving me nuts!

Nimoy 09-01-2003 05:19 PM

CAN IT BE TRUE? IS THERE NO ALSA GURU OUT THERE THAT CAN HELP????

- Unless a guardian angel steps in like YESTERDAY.... XP might be the only solution.... must it really come to that?

Nimoy 10-12-2003 09:00 AM

He he - I took they easy way out :) "The best of both worlds" - Now all I have to do is wait 4 2.6 then ALSA should run... (I hope) - So consider the thread closed... For now anyway :)


All times are GMT -5. The time now is 04:07 PM.