LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Linux problems (freezing) (https://www.linuxquestions.org/questions/linux-software-2/linux-problems-freezing-220874/)

[Aerox] 08-22-2004 10:19 AM

Linux problems (freezing)
 
Hi guys.. I'm new here.. I'm new in Linux, also...

So, here are my problems...

I tried to install Mandrakelinux 10.0. The install was succesfull. The first problem started when I wanted to launch linux for the first time.. During booting, i't freezed when he was "building Mozzila registry" or smt like that. Anyway, It needed a hard reset. Then I tried failsafe and got into linux succesfully.

I started to search around.. Then I decided to make a new internet connection.. I made it all, then it wanted the first CD. It started copying and than it freezed. Mouse was dead, hard drive didn't move, CD-rom also on stand by. So, hard reset again...

Then I got in again.. Watched a DVD, then i wanted to listen music, and it freezed again, when i was searching the hard drive..

So, it freezes randomly.. I don't know what to do.. I tried to reinstall twice, but it's the same thing...

I'm starting to lose my nerves.. If I can't fix this, I'm gonna try fedora core 2..

Please help me guys.

Thank you.

Regards,
Jaka
Slovenia

hw-tph 08-22-2004 10:44 AM

What kind of hardware do you have? Some motherboards, most notably nvidia nforce2 and 3 based boards, have severe APIC problems. Passing "noapic" to the kernel at boot-time solves this in most cases.


Håkan

JARofHERB 08-22-2004 10:58 AM

that as well,,as maby youre system is frezing because youre processor is running a tad to hot?
does it freze like this under w$ndows?

qwijibow 08-22-2004 11:07 AM

everyone is probably sick of hearing this... but it has to be said...

did you download mandrake ? if so, did you test mandrake's iso md5sums ?

on the server you diwnloaded mandrake, there will be a file named the same as the mandrake iso, except it will end in '.md5' download that and save to the same folder as the iso's then use the program md5sum to test the iso...

this will test to see if the mandrake iso was corrupted, or tampered with.

also... maybe Linux itself wasnt frozen,,, just the graphical X server... if it happens again.. see if you can Ctrl+Alt+F2 into a second login console, ten login as root. and 'shutdown -h now' instead of hard reseting.

amosf 08-22-2004 12:23 PM

Are you using KDE... Disable the KDE sound server in the KDE control center. This has a habit of locking up the system esp when using media type apps...

[Aerox] 08-22-2004 01:43 PM

Hi guys...

The configuration of my system is:

Amd athlon 2500+
Abit NF7-S v2.0
Maxtor 120gb sata
Kingston HyperX 512mb
Radeon 9800pro

I had to use the command "linux noapic nolapic" to pass the installation. If I started it without this command, it freezed randomly.. Once at the first Cd, and the second time at the third CD. Then i used this command, and it worked okay..

So, I think this command is the solution.. How can I add it to the bootloader?

Btw, the system isn't overheating, the temperatures are around 44.
I didn't download it from a web site, I got the iso files on a CD in one of Slovenian Computer magazines.. There is also a guide, but it says nothing about freezing and so...

Sorry for these n00b questions, but I want to explore Linux, because I like it..


Thank you all.

REgards

EDIT:

I tried again, when it freezed, i tried ctrl + alt +f2 and it has no response.. I also tried alt + ctrl + backspace.. No response...

Anyway, i got to the bootloader setting.. The onli selected item is "Force NO apic".
There are 2 remaining options.. One to allow apic, and another one to force no apic on hdd or smt..

So, i'm lost.. No more ideas.. I would really like some help, before I format the whole thing and install fedora core 2 :\

qwijibow 08-22-2004 02:38 PM

do you use lilo or grub... ? if you use grub, add the noapic lines as kernel parameters in the grub congig file /boot/grub/menu.lst

example...
kernel /bzImage root=/dev/hda1 ro vga=755 mem=nopentium noapic (other kernel parameters)

im not sure about lilo.

[Aerox] 08-22-2004 02:45 PM

I use Lilo.

Should I use Grub? I don't know which one is better.. I just want that it works normaly..

qwijibow 08-22-2004 06:10 PM

lilo and grub both work... i prefere grub, but thats just my opinion.
search this forum for a guide on how to add kernel options / parameters in lilo then add use it to add your noapic option.... i think lilo keeps its config in /etc/lilo.conf have a look in it, maybe it will be self explaitory..

hw-tph 08-22-2004 06:41 PM

In Lilo you can add the line:
Code:

append="noapic nolapic"
...to /etc/lilo.conf and then run the command /sbin/lilo to make the changes apply.


Håkan

[Aerox] 08-22-2004 06:50 PM

okay, does it matter where i put it in the file?


All times are GMT -5. The time now is 05:00 PM.