-   Linux - Software (
-   -   Linux Mint on a flash drive (

DJNOS 06-08-2009 02:14 PM

Linux Mint on a flash drive
Hello this is my very first post. I'm sure this question has been asked alot but here goes:

I am installing Linux Mint on a 4.0G flash drive. The installation goes great and I did all that I was suppose to do. When I go to reboot my laptop, it says invalid or damaged bootable partition.

I started my laptop and hit F12 to go to the boot-up menu and chose usb drive. Does anyway have any idea what I'm doing wrong?

I am not a computer savy kinda guy so I don't understand much tech talk. lol. yes I am trying to do this by myself without bringing this to a shop or spending money on it. I've already been through 3 hard drives and I'm not spending any more on this machine. I would like to see if I can get this to work. If you can help with this I would greatly appreciate it.

DJNOS 06-08-2009 03:33 PM

Am I in the wrong forum or something? 42 views and no repies.

jimbo1708 06-08-2009 03:38 PM

investigate a product called remastersys

DJNOS 06-08-2009 03:41 PM

Is that going to solve my issue?

linus72 06-08-2009 03:50 PM

No, it is not.
What is the output of , as root, "fdisk -l" while usb is plugged in?
with usb plugged in, BUT UNMOUNTED, what is the output of "fsck /dev/sdxx"
where "xx' is usb drive?

DJNOS 06-08-2009 03:56 PM

Well I appreciate the reply but I have no idea what you are talking about. Like I said, I don't speak that language. LOL. I'm a basic computer user trying to get linux to work on a flash drive. That's as simple as I can explain it.

jasohl 06-08-2009 03:57 PM

Could you post the partition table that was created?
From a terminal type (where sdc is your usb device):

fdisk -l /dev/sdc
Also, do you have other Linux installs, besides the USB? If not, most of this stuff will need to be performed from a live distro.
Have you ever booted from a USB before? Have you tried booting it from another computer to determine if it is in fact the USB/Install.

linus72 06-08-2009 04:04 PM

Yes, please give as much info about distro's you have tried and complete specs on the computer as in what you know about it-make, ram, etc.

DJNOS 06-08-2009 04:11 PM

I have Mint on a cd but I wanted to install it to USB and boot from there. My hard drive is out so I want to use my laptop without even fooling with the hard drive. I have not done this before so I am not sure if it's just my pc or the actual UBS. It could be that I can't boot from USB but in BIOS it does give me the option but then gives me the error > invalid or damaged bootable partition. I have a Dell Inspirion 2200. I have had it since 2004 and honestly can't remember all the specs. It's time to get a new one but I just wanted to see if I can get this to work before I go out and to that. I think I have like 512 ram and 1.2 or 1.8 processor speed. It is a celeron processor, which is something I'm not happy with.

linus72 06-08-2009 04:18 PM

OK, so please boot off Mint CD, at desktop open a terminal and become administrator; which is called "root" in Linux.
To become root in Mint, in terminal type "sudo su"

Plug in usb, it should auto-mount it; type in terminal after inserting USB
"fdisk -l"
Note what the output is.
Now, right-click on USB icon on desktop and select "unmount"
Now type in terminal "fsck /dev/sdxx" where xx is device name.
the output of fdisk -l will tell you name, should be sda1, sdb1, sdc1, sdd1, sde1, sdf1, or sdg1.
What is the output of both "fdisk -l" and "fsck /dev/sdxx"
Post what it outputs here please.
Then we'll get on to installing, etc

jasohl 06-08-2009 04:19 PM

Check out this site:
Its got tutorials for installing different Distros on USB Drives. There is actually a new one on installing Mint 7 from Windows.

DJNOS 06-08-2009 04:21 PM

Thanks for that link but I already did all of that. And now I'm having the issue I'm referring to so I'm trying to figure out what's next.

linus72 06-08-2009 04:24 PM

OK, please do the fdisk -l thing, and also how did you format usb, or is it factory formatted and you haven't done anything to it?

I believe you have a corrupted or improperly formatted usb.

DJNOS 06-08-2009 04:44 PM

I did what you said. I will tell you along with the steps:

1. went to sudo su
2. loaded usb
3. typed in fdisk -l
4. for output:
Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xaae0aae0

Device Boot Start End Blocks Id System
/dev/sda1 * 1 9728 78140128+ 7 HPFS/NTFS

Disk /dev/sdb: 4005 MB, 4005560320 bytes
21 heads, 21 sectors/track, 17740 cylinders
Units = cylinders of 441 * 512 = 225792 bytes
Disk identifier: 0x404d1138

Device Boot Start End Blocks Id System
/dev/sdb1 * 19 17741 3907648 c W95 FAT32 (LBA)

DJNOS 06-08-2009 04:45 PM

Reading what you wrote I may have not formatted the usb properly. I did not know that a brand new USB had to be formatted.

All times are GMT -5. The time now is 11:43 AM.