LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Linux Mint 19 Cinnamon: BOINC Manager crashes, won't run. (https://www.linuxquestions.org/questions/linux-software-2/linux-mint-19-cinnamon-boinc-manager-crashes-wont-run-4175643368/)

cjspizz 11-29-2018 08:30 PM

Linux Mint 19 Cinnamon: BOINC Manager crashes, won't run.
 
OS: Linux Mint 19 Tara
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
Kernel: 4.15.0-39-generic x86_64
CPU: AMD FX-6300 Six-Core
GPU: AMD/ATI Curacao PRO [Radeon R9 270]
BOINC Version: 7.9.3 x86_64-pc-linux-gnu

I'm relatively new to linux, having played with several flavors over the years, but never finding one that allowed me to ditch Windows. I've been running BOINC almost non-stop on my Windows PC for about 10 years. About 4-6 weeks ago, I decided to try again and setup a Win 10/Mint 19 Cinnamon dual-boot and haven't booted into Windows since!

One of the first things I did in LM was install BOINC packages, including the BOINC Manager. I attached to BAM! and all my projects with relative ease. BOINC, including the Manager, was working great.

Before leaving town for Thanksgiving, I installed an AMD proprietary driver (AMD Radeon Software Crimson Edition 15.12 Proprietary Ubuntu 14.04 x86_64 Minimal Video Driver for Graphics Accelerators (Non-X Support)). Everything seemed fine, and I left my machine crunching while I went out of town for Thanksgiving.

When I got back, I found several things had gone screwy. Among them, (1) the BOINC Manager disappeared (but the BOINC Core Client was still crunching in the background), and (2) I was getting this notification:

Quote:

Cinnamon is currently running without video hardware acceleration and, as a result, you may observe higher than normal CPU usage. There could be a problem with your drivers or some other issue. For the best experience, it is recommended that you only use this mode for troubleshooting.
I realized I had installed the wrong video driver, so fixed that by uninstalling the proprietary AMD driver. After reboot, the video hardware acceleration issue was resolved.

Unfortunately, BOINC Manager still wouldn't run. I think the two may be related.

When I click the BOINC Manager icon, BOINC Manager appears for a second or two in the System Monitor > Processes tab then disappears. BOINC Manager never shows up on my desktop.

I've tried uninstalling BOINC Manager, rebooting, then reinstalling, but the result is the same. I tried starting it via the terminal. Still same result.

The only way I can get BOINC Manager to run is by
Code:

sudo boincmgr
but the instance that opens is empty—no projects or tasks, even though I can see the BOINC daemon in running in the background using
Code:

sudo /etc/init.d/boinc-client status
I went looking for info on my system and found the following:

(1) /home/cjspizz/.BOINC/stderrgui.txt contains about a dozen or so errors that all look (mostly) like this:
Quote:

(boincmgr:12564): Gtk-CRITICAL **: 17:46:03.513: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
(2) /var/lib/boinc/stdoutgpudetect.txt
Quote:

Error: Fail to load fglrx kernel module!
(3) /home/cjspizz/.BOINC Manager looks like a config file.

I searched for the first error message online, and it seems to be a minor issue and seems to suggest BOINC Manager maybe shutting down because of some display size or location problem (that's why I mentioned the GPU driver problem earlier).

Based on the 'fglrx' reference, the second error ("Fail to load fglrx kernel module!") also seems related to the ill-fated AMD driver install.

I've also fully reviewed and explored this information, but they haven't led me to a solution:
That's everything I can think of. I really hope someone can help. Thanks!

cjspizz 12-01-2018 11:15 AM

In case anyone else comes looking for the same or similar issue, I got a simple fix in another forum: "If you have a file with a name something like /home/cjspizz/BOINC Manager-cjspizz and it only contains a number (process ID) then remove the file and try again."


All times are GMT -5. The time now is 03:02 AM.