-   Linux - Software (
-   -   Linux Firefox Not Working on (or why I hate M$) (

MBA Whore 06-28-2008 08:51 PM

Linux Firefox Not Working on (or why I hate M$)
Hi all,

I run Linux MEPIS 7.0 and use firefox.

Everytime I try to login to to check my mail, I get the following message:

>>JavaScript required to sign in

Windows Live ID requires JavaScript to sign in. This web browser either does not support JavaScript, or scripts are being blocked.

To find out whether your browser supports JavaScript, or to allow scripts, see the browser's online help.<<

I disabled "noscript" and "adblock". I verified that Firefox's settings are allowing java and javascript. I still get this message while using Linux and Firefox.

Strangely, this only started happening in the past few months - for the longest time I had no troubles. Stranger still, I have no problem while using Windows and Firefox.

Short of nuking Redmond, what do you recommend I do to resolve this problem?

wabbalee 06-28-2008 09:13 PM

Hello again, i have the same under ubuntu 7.10 with my partner's pc and i installed firefox 3.0 and that fixed it. it can be installed besides your current firefox. ff3.0 is still in beta i think. try to find it in synaptic first.

good luck!

slackhack 06-28-2008 09:17 PM

get a gmail account? :D

my first guess would be that it's possibly a user agent issue. to test that, either change the user agent in about:config, or install the user agent switcher extension and try one of the MS user agents from the list (installs to tools menu).

oskar 06-28-2008 09:43 PM

I'm pretty sure java script is included in all the pre-installed firefox versions, so that's probably a wrong error.
Firefox 3 is final, so if it works with FF3, I would just get that one.
A quick search brought up this:
(there's a possible solution after the rant)

This might be worth a look:

Wine-doors is also focusing on IE... they're very early in development though:

neothephoenix 06-30-2008 12:25 PM

Hi all,
I am using Archlinux Duke with Bon Echo as my web browser. I was having exactly the same problem as the thread mentioned.
I simply upgraded to firefox 3 and the problem got resolved.
Though my Bon Echo(or links even) never gave any error messages like "enable javascript", yet it seems now that it was afterall a javascript problem. Seems like MS is trying to shut down its resources to Linux users.

Thanks, one and all...

evaluatinglinux 10-17-2008 01:15 PM

Try reinstalling FF2 ... Else - better still - install FF3.

Debian Kernel

All times are GMT -5. The time now is 09:33 PM.