LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-08-2005, 05:46 AM   #1
sharkzf6
Member
 
Registered: Jan 2005
Location: San Antonio, TX
Distribution: Debian Sarge, SuSE 9.2, Ubuntu Warty, Slackware 10.1
Posts: 63

Rep: Reputation: 15
Angry Linux clock thinks it owns my system


I realize this is going to sound stupid but I have to say it's p*****g me off. For some reason, Linux thinks it owns my hardware clock. I want my hardware clock set to my local time and that's the time I want to see in my taskbar and I don't think I should have to lie to the clock applet to trick it into thinking that's UTC time. I don't give a crap about UTC time, I need the time where I'm at...period. Can someone please tell me how to fix this. It seems obvious when you set it up but it always ends up displaying UTC time when you tell it to use the local time zone. I live in the central time zone US, that's what I want to see on my hardware clock and my desktop. It ain't that difficult. Damn!
 
Old 03-08-2005, 06:33 AM   #2
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Given your attitude, you really don't deserve this, but:
http://www.computerhope.com/unix/udate.htm
 
Old 03-08-2005, 08:28 AM   #3
sharkzf6
Member
 
Registered: Jan 2005
Location: San Antonio, TX
Distribution: Debian Sarge, SuSE 9.2, Ubuntu Warty, Slackware 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by scuzzman
Given your attitude, you really don't deserve this, but:
http://www.computerhope.com/unix/udate.htm
Wow, I've never been scolded on a forum before

Look, this time thing is really too complicated. I'm sure it seems easy enough for people who have done it. I'm sure I'll think it's a no-brainer one day. But, for a newb that's use to Windows/DOS, it's downright ridiculus. Even the link you provided was no help to me because it didn't explain the string syntax, it just gives info that someone who already knows how to do it would understand. And the KDE clock app that's taken over my system time must have been written by a dyslectic. I know why it's acting the way it is. I had my hardware clock set on UTC using SuSE but the clock app in that distro actually worked from Gnome. It understood that the hardware clock was set to UTC but I wanted my desktop time to be "local" as in, the time zone where I live. So, when Slackware installed it asked me if my hardware clock was UTC and I said yes. Little did I know it was going to make me live in Great Britain's Time Zone every time I select the local time zone display... What a pain in the a$$!
 
Old 03-08-2005, 08:34 AM   #4
sharkzf6
Member
 
Registered: Jan 2005
Location: San Antonio, TX
Distribution: Debian Sarge, SuSE 9.2, Ubuntu Warty, Slackware 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Ya know, I'm sitting here kicking myself cause I just realized I don't have to use the moronic clock applet that KDE uses by default. I'll just remove it from the panel and download one that's written for idiots like me and use it to set the time.
 
Old 03-08-2005, 09:12 AM   #5
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
Quote:
Originally posted by sharkzf6
when Slackware installed it asked me if my hardware clock was UTC and I said yes.
if that's the case, then you just have to run pkgtool (as root), go into setup and then timeconfig... there you will be able to change the option you set during the install... the two available options are:
Quote:
- Hardware clock is set to local time

- Hardware clock is set to UTC
just my two cents... good luck...
 
Old 03-09-2005, 09:10 AM   #6
sharkzf6
Member
 
Registered: Jan 2005
Location: San Antonio, TX
Distribution: Debian Sarge, SuSE 9.2, Ubuntu Warty, Slackware 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by win32sux
if that's the case, then you just have to run pkgtool (as root), go into setup and then timeconfig... there you will be able to change the option you set during the install... the two available options are:

just my two cents... good luck...
Where were you when I needed you ...
Thanks, I'm much calmer today...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 08:19 PM
System Clock Way Off JazzMastaJim SUSE / openSUSE 13 10-10-2005 04:06 AM
system clock,hardware clock varunbihani Linux - Newbie 2 07-23-2005 10:04 AM
Who owns a linux or computer related website? h1tman General 7 03-25-2004 08:06 PM
system clock vs. CMOS clock dtamajka Linux - General 7 12-11-2003 06:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration