LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-31-2018, 09:14 PM   #1
rup1034
LQ Newbie
 
Registered: May 2011
Posts: 23

Rep: Reputation: 5
Unhappy Linphone won't compile. Mediastreamer2.


First off I am using slackware-current 64/multilib with ktown5 which is a fresh install with the newest libraries. I am trying to get linphone working.

I made an attempt at compiling linphone from git v4.x. I keep getting failures at mediastreamer2, first failure was because they were searching /usr/lib instead of /usr/lib64 despite the entire rest of the project using /lib64 dont know why mediastreamer has a different config was getting libXext.so wrong format. So i manually navigated to the media streamer source directory within linphones git clone and did the following to force it to use /usr/lib64 as how it should be with a 64 bit system:
Code:
cd /usr/src/linphone-desktop/submodules/mediastreamer2/
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib64
make -j8
It gets further this time but has a serious error with msfactory.c and I cant find much documentation about anyone having this happen via google. I do not think many people compile this program successfully or just use debs or rpms which is not a option for me.

Code:
make[3]: Entering directory '/usr/src/linphone-desktop/submodules/mediastreamer2/src'
  CC       base/mscommon.lo
lines 1-30base/msfactory.c: In function ‘ms_factory_load_plugins’:
base/msfactory.c:620:85: error: ‘%s’ directive output may be truncated writing up to 255 bytes into a region of size 64 [-Werror=format-truncation=]
    snprintf(plugin_name, MIN(sizeof(plugin_name), (size_t)(ext - de->d_name + 1)), "%s", de->d_name);
                                                                                     ^~
base/msfactory.c:620:4: note: ‘snprintf’ output between 1 and 256 bytes into a destination of size 64
    snprintf(plugin_name, MIN(sizeof(plugin_name), (size_t)(ext - de->d_name + 1)), "%s", de->d_name);
    ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
make[3]: *** [Makefile:1665: base/msfactory.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[2]: *** [Makefile:1028: all] Error 2
make[1]: *** [Makefile:638: all-recursive] Error 1
make: *** [Makefile:545: all] Error 2

Is anyone able to help me get linphone compiled is there any patches or version regressions I could use that this does not happen on.
 
Old 02-01-2018, 03:16 PM   #2
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 977
Blog Entries: 2

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Quote:
cc1: all warnings being treated as errors
Is there an option to turn this off?

BTW how big a computer do you have? -j8? I do good if I can use -j2 on my pc's
 
Old 02-01-2018, 03:35 PM   #3
BeaverusIV
Member
 
Registered: Oct 2004
Location: New Zealand
Distribution: Arch Linux 2010.05
Posts: 135

Rep: Reputation: 18
I'm no expert but 2 things jump out at me:

> -Werror=format-truncation=

> cc1: all warnings being treated as errors

Maybe try setting up the build to not fail on warnings or disable that particular warning?
 
Old 02-02-2018, 12:03 AM   #4
rup1034
LQ Newbie
 
Registered: May 2011
Posts: 23

Original Poster
Rep: Reputation: 5
I tried a few different things and managed to compile it using a slackbuild but with modifications, apparently slackbuilds.org has a patch built in to fix that mediastreamer compile issue. I added --disable-video and --disable-upnp. Managed to build a older version of linphone 3.12.0. I don't care about the v4l crap.

But linphones build scripts are very broken on a few things. v4l utils tries loading a few files out of /usr/lib which breaks that part of the build and despite searching makefiles trying to find stuff to change to /usr/lib64 I was unable to succeed I was at this all afternoon. Mediastreamer has alot of errors. Setting compiler errors as warnings to disabled only showed me a slew of further errors.

I will just consider this solved for the time being and use a older version. I will post here if I figure out getting 4.x built ever. And perhaps post a slackware .tgz package file.
 
  


Reply

Tags
compile error, linphone, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions on Linphone blank video and using Linphone in Jitsi. linustalman Linux - Software 5 03-02-2015 03:41 PM
Qt v3.3.8 won't compile... BlueSpirit Slackware 8 01-04-2014 01:55 AM
How to compile a linphone 3.3.2 source code venki86 Linux - Newbie 2 03-24-2011 01:54 AM
linphone sancher Linux - Software 4 11-06-2009 12:40 AM
linphone fathgrufith Linux - Software 8 09-17-2009 09:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration