Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-30-2014, 01:23 AM   #1
LQ Newbie
Registered: Oct 2014
Posts: 2

Rep: Reputation: Disabled
Talking linphone + ALSA - multichannel digital setup thru ALSA - Echo Layla3G card

Hi ... am using Debian Wheezy on a special purpose machine that really has nothing more than ALSA, Jack Audio, tighvnc, blackbox and formerly Skype now Linphone.

Everything was fine with Skype + Jack + ALSA UNTIL I was forced to upgrade Skype to 4.3 which doesn't support ALSA. The driver for my soundcard (Echo Audio Layla3G) is made for ALSA so I'm stuck using it. Skype was able to use Jack so I just did everything thru Jack ... easy

My problem is a terrible echo / loop when I use the digital ins/outs which are on card0:dev1 ... when Linphone uses the analog side which is the default card0:dev0 it sounds fine. ALSA has named both devices LAYLA3G so I can't declare the device by name in .linphonerc .

I modified my existing asound.conf to show;

cm.!default rate_convert

pcm.rate_convert {
    type plug
    slave {
        pcm "hw:0,1"
        rate 44100
        period_size 1024
        buffer_size 4096
This gets linphone to the digital as I'm forcing ALSA to make card0:dev1 the default BUT I get a terrible echo - you can tell the input is being routed to the output and vice versa - a really bad loop. (The rate is needed because I connect to my mixer via ADAT and when the rate is set in ALSA, it sets the rate in the mixer.)

I'm wondering how I can get linphone to use only the digital ins / outs without getting the echo?

***Bonus points if you can show me how to use only channel 3 + 4 out of my 8 digital channels AND mix them to mono on the input side and stereo from mono coming out.

Any help is def appreciated ... There's a lot of documentation out there but nothing that I understand well enough to solve this problem (plus making calls to myself for troubleshooting is a pain) Thanks! ~Rich
Old 10-31-2014, 04:33 AM   #2
Registered: May 2013
Posts: 89

Rep: Reputation: Disabled
Your file should begin with "pcm", not "cm".
Old 10-31-2014, 11:57 AM   #3
LQ Newbie
Registered: Oct 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
it does ... that is a typo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to switch my alsa card 0 and alsa card 1 in ALSA? frenchn00b Debian 10 12-11-2009 01:16 PM
Interleaved/Multichannel audio programming with ALSA on linux- kernel Mohan.Sundram Linux - Kernel 0 08-27-2008 06:31 AM
USB sound card not detected by ALSA but is by lsusb, using alsa 1.0.15 mjkelly93 Linux - Hardware 1 10-20-2007 11:23 AM
Creative 5.1 sound card&speakers fedoa5 Alsa setup help needed lizard_king825 Linux - Hardware 0 08-24-2006 05:41 PM
Alsa, Echo Gina 24, Kanotix visiongtr Linux - General 0 07-07-2005 10:59 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:33 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration