Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 11-07-2003, 06:05 PM   #1
Registered: Oct 2003
Location: UK
Distribution: Slackware 8.0
Posts: 56

Rep: Reputation: 15
LinNeighborhood problem with gtk

I've been trying to install LinNeighborhood. It require the GTK+ library, so i downloaded the GTK+ 2.2.3 library.

I tried to install GTK but it requires a more recent version of pango (whatever that is!) So i downloaded pango 1.2.5.

I tried to install pango 1.2.5 but it requires a higher version of glib 2.1.4!!!!! So i downloaded glib 2.1.5.

I installed glib 2.1.5 with no errors, closely following the install instructions. With my new glib installed i tried again to install pango but it said......

checking for pkg-config... /usr/local/bin/pkg-config
checking for fontconfig >= 1.0.1... Package fontconfig was not found in the pkg-config search path.
Perhaps you should add the directory containing `fontconfig.pc'
to the PKG_CONFIG_PATH environment variable
No package 'fontconfig' found
configure: WARNING: No fontconfig found, skipping tests for FreeType and Xft
checking for pkg-config... (cached) /usr/local/bin/pkg-config
checking for GLIB - version >= 2.1.3... no
*** Could not run GLIB test program, checking why...
*** The test program compiled, but did not run. This usually means*** that the run-time linker is not finding GLIB or finding the wrong
*** version of GLIB. If it is not finding GLIB, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/
to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error:
*** Glib 2.1.3 or better is required. The latest version of
*** Glib is always available from

But i understand why it wants a higher version than 2.1.3 when i've installed 2.1.5. Does anyone know what i'm doing wrong? It seems to be getting very complex for installing a program!



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
gtk+ 2.4.14 problem, how do I execute GTK? nautal Linux - Software 2 06-17-2005 06:09 PM
LinNeighborhood problem mwales Linux - Software 1 01-13-2005 10:21 PM
LinNeighborhood Problem AmdMhz Linux - Software 10 10-18-2004 12:54 AM
Problem using Linneighborhood to access XP share preiter Linux - Newbie 1 02-04-2004 11:11 PM
LinNeighborhood installtion problem mobassir Linux - Software 1 09-27-2003 09:17 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:59 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration