-   Linux - Software (
-   -   LILO nightmares - Mandrake 9.1 (

Malibyte 07-29-2003 03:48 PM

LILO nightmares - Mandrake 9.1
Just upgraded Mandrake 8.2 to 9.1 on my laptop (Dell Inspiron 8100). Mdk 8.2 has been working fine, but because of the age of some of the base packages, I was getting into dependency hell on occasion. So, went ahead and upgraded to the latest version. All went smoothly until it went to install the new version of the bootloader. First, it wasn't able to run mkinitrd for the new kernel. Second, it didn't add the new kernel image to the lilo.conf file (though the image was placed in the /boot directory) and it would not let me configure lilo.conf through the installation/configure GUI (though I could do it from a console (ctl-alt-F2). Third, running LILO itself bombed. I couldn't make a boot disk because the floppy drive wasn't installed, and there's a reason I can't run have the floppy and the CD-ROM at the same time (main CD-R drive flaky; secondary CD-RW/DVD drive and floppy can't both be in at the same time).

Since this wasn't going anywhere I tried to reboot: "LI"

Rebooted into rescue mode from the install CD. No sweat, but can't run mkinitrd from there either - mainly because if I chroot to /mnt, the /proc directory can't be found, so it aborts. Can't run LILO, for the same reason - chroot to /mnt makes the "real" /dev directory unavailable (as does /mnt/sbin/lilo -r /mnt). I have another Mdk 8.2 system, so I made a boot floppy from it (its / partition (/dev/hda5) is the same as the laptop's). It wouldn't boot ("unable to get an initial console" or something very similar).

Can't even try using GRUB either - grub-install can't find /dev/hda5 (the install partition; I have System Commander on /dev/hda) if I chroot to /mnt, and won't find sed if I run it from /mnt/usr/sbin, therefore aborts.

I have about three hairs left...I've torn the rest out. Any help would be appreciated.

Thanks -- Bob

Malibyte 07-29-2003 08:08 PM

Finally got it fixed. The problem was that devfs wasn't mounted by either the install CD or the old boot floppy. Whe I used the boot floppy with the parameter "devfs=mount" I was able to boot from it and get everything fixed.

Electro 07-29-2003 08:18 PM

Do you mind listing the filesystems for your /dev/hda. I think you are using a different filesystem that the new kernel doesn't have. Usually it supports ext2 and ext3.

Did you try adding 1 to the boot loader. This will go in single user mode so you can run any program with out restrictions.

If I was you, I will be downloading Knoppix and getting your data off the hard drive using the network. If anything happens, you won't freak out even more. Also you can do mkinitrd in Knoppix. Just run Knoppix in runlevel 1.

Its sometimes easier to do a full OS install than doing an OS upgrade. You could have install urmpi. Then upgrade your packages from there.

Malibyte 07-29-2003 08:28 PM


Funny you should say that...I have Knoppix downloading (albeit incredibly slowly) onto another machine (coming over at about 2.2KB/sec on a 1.5Mb/s DSL line!).

I did have the 8.2 system backed up onto a removable HD, so all would not have been lost...I simply wasn't looking forward to having to do the restore.

As I said, devfs was the culprit...glad it's going away in 2.6. The laptop is up and running now.


All times are GMT -5. The time now is 02:54 PM.