LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Lilo errors (https://www.linuxquestions.org/questions/linux-software-2/lilo-errors-461951/)

Slick666 07-07-2006 09:36 PM

Lilo errors
 
Hello all I am having a persistent problem with lilo on my Slackware system. Below is a description of the problem.

Precondition: Compiling 2.6 kernel

Boot machine
make clean
make bzImage
make modules
make modules_install
cp ./arch/i386/boot/bzImage /boot/kernel2.6
lilo

All executed successfully and the machine was rebooted. Upon reboot the machine completed all hardware initialization and at the point where the machine beeps and the lilo screen displays there is a beep but the only output is what is below

L 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 40 .....

and so on.

My initial thought is that some lilo did not execute completely/correctly. I changed my lilo.conf file and it had booted from the kernel file "kernel2.6" and it has done this in the past. All I did was overwrite the kernel file and execute lilo.

What I have done to fix the problem is temporarily attached a hard drive and booted from the slackware cd.
I tried executing /sbin/lilo to repair it with no success. I copied over the few files on the machine not backed up yet.
I then executed cfdisk and repartitioned the disk. I then executed the slackware setup. I got all the way through the install but at the point of setting up lilo the install program said it had encountered and "error".
I should let you know that this installation is on a raid 5 array so I booted to the raid controller card's bios and completed hardware checks.
After everything checker out I tried to install Slackware again with the same error.
I rebuilt the raid array.
I tried to install slackware again and got the same lilo "error" again:scratch:

I setup lilo in the Master Boot Record (MBR) but I figured that after rebuilding the array I would surely erase that. The hardware passes it's own Built In Self Test. If any one has any ideas to what the problem is it would be greatly appreciated

bathory 07-08-2006 08:37 AM

According to the lilo manpage the error code 40 means:
Quote:

40 cylinder>1023 (LILO)
So I guess you have to add
Code:

lba32
in your /etc/lilo.conf.
Also in your procedure of compiling the new kernel you didn't mention if you've also copied the new System.map in /boot/System.map-whatever-is-in-lilo.conf

Slick666 07-08-2006 04:15 PM

I didn't copy the System.map

I must admit I am still generally inexpierenced, but I have never in 4 Slackware installations copied that file. From what I've looked up the System.map is some table of values. I'm not sure why that should be copied?

Also, unfortunately in my attempt to fix the machine I destroyed the lilo installation but I'm an confused. If I did not edit the lilo.conf file why would it work one boot but not the next boot?

In my progress I have been able to boot off the slackware CD and chroot the the current installation and run lilo sucessfully. The current boot time error I get is "error loading operating system".

In the lilo.conf file I have...
1 pointed the correct drive "/dev/sda1"
2 commented out the windows boot potion of the code

bathory, I will add the line you suggested "lba32" and see what happens.

Thanksagain for all your help

Slick666 07-19-2006 02:23 PM

I am an Idiot!

After formatting my raid successfully I was getting the error "error loading operating system"

Here is what was wrong. When I grabbed my information off my raid array I was unable to use the floppy or network so I attached an IDE hard drive through the pci-ide card that had the cd-rom on it. After booting to the cd-rom and transferring the data I left the drive on the ide-card so I could transfer the data back off
!!!!THAT WAS THE MISTAKE!!!!
After reinstalling the Slackware to the raid array and rebooting since the ide-card came up first (you want to check the cd-rom first at boot time) and there was an IDE hard drive on that card. The computer would try to boot from that card on the ide-disk, which had no operating system, therefore I got the error.

I spent a week reformatting, repartitioning, I also did a low lever consistency check on all the drives in the array. I finally discovered the error because I removed the drive (since it looked like I wouldn’t need it for a while) reinstalled slackware witch worked this time. And then tried to boot with the hard disk on there to retrieve the information. In any event there's your resolution. Always check your boot sequence. I have a feeling I won't be making this mistake anytime soon


All times are GMT -5. The time now is 11:43 AM.