LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-23-2004, 08:43 AM   #1
mch
LQ Newbie
 
Registered: Sep 2002
Location: malaysia
Distribution: Redhat
Posts: 26

Rep: Reputation: 15
lilo can not be install in 80G hard disk


helo guys,
i have a question and its about lilo.not the movie lilo and stich
i just bought a new 80G hard disk and i have make four partition that
is Drive C,D,E and the last drive is for linux(20G).

at first i install linux redhat8.0 and it can boot up just normal with
lilo.
but after i install win2000 in the C drive, my lilo is gone.
lucky i have the boot disk which i create when install linux.
i was trying to install back lilo but this is the error i get when i type
#run /sbin/lilo:
"device 0x0307 exceeds 1024 cylinder limit
fatal:sector 114723348 too larger for linear (try 'lba32' instead)

did anyone faced this problem before?can you guys tell me how can i solve this problem.

thanks
mch
 
Old 10-23-2004, 09:03 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 270Reputation: 270Reputation: 270
What version of lilo are you using? The error "device 0x0307 exceeds 1024 cylinder limit" exactly tells you your problem, its trying to install lilo past the 1024 cylinder. Create a new partition within that range for lilo to work properly.
 
Old 10-23-2004, 09:10 AM   #3
mch
LQ Newbie
 
Registered: Sep 2002
Location: malaysia
Distribution: Redhat
Posts: 26

Original Poster
Rep: Reputation: 15
helo trickykid,

i don't know my lilo version. by the way, how do i retrieve the lilo version?

let me show you how i partition my hard disk:
C Drive: 20G
D Drive:16G
E Drive:20G
the rest 20G is for Linux.
the /boot,/,/swap,/usr,/var,... and in the last cylinder.

you said i have to create my /boot in the C Drive?
but i did not create a partition in C Drive.

thanks,
mch
 
Old 10-23-2004, 10:35 AM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,940

Rep: Reputation: 129Reputation: 129
First, the only reason I'm posting is because Drew must be out
of town or something if he hasn't gotten back to you in 24 hours.
Edit: (Or am I reading the time thing wrong - oh, I'm sorry!)
And he's at least 5 light years smarter than me about *nix. ;^)

Boot the system again and run "/sbin/liloconfig" in a terminal
as root and install LILO in the MBR and all your problems will
disappear. NB: It goes in /dev/hda and the Linux partition to
install is your / partition and the Windoze is /dev/hda1

Your LILO entries should look something like
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
#compact        # faster, but won't work on all systems.
prompt
timeout = 50
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# ramdisk = 0     # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda6 <-- this should be your Slack / partition
  label = Slack-10.0
  read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/hda1
  label = Windoze
  table = /dev/hda
# Windows bootable partition config ends

Last edited by Bruce Hill; 10-23-2004 at 10:37 AM.
 
Old 10-23-2004, 10:58 AM   #5
TKS
Member
 
Registered: Dec 2003
Location: NC, USA
Distribution: Slackware, VectorLinux, Smoothwall, and PCLinuxOS
Posts: 40

Rep: Reputation: 15
Easiest way to do this is to boot up into RedHat....type 'lilo' and call it good


Lilo will reinstall exactly what you have in your .conf file into the MBR (master boot record).

Windows likes to kick out Linux all the time when you install it. That's why it is good to install windows first. But getting your boot loader back is pretty simple.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Hard disk and LILO BACTRATE Mandriva 2 08-04-2005 05:28 AM
Grub or LILO on a new hard disk MCG Linux - Hardware 1 11-17-2004 04:59 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 05:00 PM
Why can't lilo be installed in my hard disk? DartMol Slackware 1 01-29-2004 11:28 AM
Lilo and MBR of the second hard disk petarsabev Slackware 9 09-30-2003 11:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration