LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-05-2017, 07:52 AM   #1
cave_man()
LQ Newbie
 
Registered: Jan 2011
Posts: 6

Rep: Reputation: 0
libykpers-1-1 upgrade version


Hello,

I am trying to install keepassx under Ubuntu 16.04. I get the following error:

The following packages have unmet dependencies:
keepassx : Depends: libykpers-1-1 (>= 1.17.3-1~ppa2~xenial1) but 1.17.2-1 is to be installed
E: Unable to correct problems, you have held broken packages.

Then I try to update libykpers-1-1

sudo apt-get install libykpers-1-1
libykpers-1-1 is already the newest version (1.17.2-1).

How do I get to version 1.17.3?
 
Old 02-05-2017, 04:38 AM   #2
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Buster (Fluxbox WM)
Posts: 1,390
Blog Entries: 52

Rep: Reputation: 359Reputation: 359Reputation: 359Reputation: 359
You can manually install newer versions of libraries, using 'dpkg -i package-filename' after downloading them. For keepassx under Ubuntu 16.04, you will only need one or two libraries from Ubuntu 16.10, namely libykpers and libjson-c3.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade a Version rasidrasid Linux - Software 3 01-27-2012 06:04 PM
How to upgrade php from version 5.1.6 to version 5.3.6 on Centos Manpasand Linux - Server 2 08-09-2011 01:54 AM
[SOLVED] how to upgrade ubuntu any version to any without losing last version golden_boy615 Linux - General 6 05-22-2011 12:21 PM
[SOLVED] Please upgrade Operating System version to 2.6.5-7.97-bigsmp - the current version is panneer_dxb Linux - Kernel 1 04-10-2011 03:16 PM
How to upgrade php from version 5.2.10 to version 5.3.3 on Centos ashlule1 Linux - Newbie 3 10-18-2010 02:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration