LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   libstdc++-libc6.2-2.so.3 (https://www.linuxquestions.org/questions/linux-software-2/libstdc-libc6-2-2-so-3-a-409210/)

Nau 01-29-2006 04:59 AM

libstdc++-libc6.2-2.so.3
 
I've got the idea to install and play pinball on linux. I downloaded it, installed it
without trouble and then run it..but:
/cs-pinball: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory

I've heard that many Mandriva problems can be solved through easyurpmi site.
I'm in doubt that this one is one of them. But in that case i don't know what sources and dropdown lists i should use..

I have a felling that installing this libraries is danger overtaking but i'm willing to try if there is quite simple solution
Thanks!

b0uncer 01-30-2006 02:40 PM

First step is to find out which package it's in, then get the package, install it and see if that helps..probably the only way, if your game won't run without it :)

webterractive 01-30-2006 08:04 PM

What Mandriva do you have? And libstdc++libc6.2-2.so.3 is this package libstdc++2.10 that you will need. Its used by some older programs like emule. Its not installed by default here is the full rpm name:

libstdc++2.10-2.96-0.83mdk.i586.rpm

Nau 01-31-2006 06:09 AM

Thanks for the package name! I installed it and the problem with the share libraries is gone!
But i've got the other one, never saw anything like it during the installations on linux:
i ran ./cs-pinball and got:
Warning: Crystal Space installation directory not detected.
Warning: Crystal Space installation directory not detected.
WARNING: could not load plugin 'crystalspace.kernel.vfs'

What does it mean?

webterractive 01-31-2006 08:23 AM

I really don't know what to tell you, umm you should try googling it. I have never really tried games on linux.

Give this a try:

http://community.crystalspace3d.org/...ic,125.15.html

it seem like this guy is having troubles with the same thing that you are.


All times are GMT -5. The time now is 02:21 PM.