LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Libre Office 'save as' window too large on HP laptop (https://www.linuxquestions.org/questions/linux-software-2/libre-office-save-as-window-too-large-on-hp-laptop-4175659330/)

AntonyFromWatertown 08-17-2019 09:48 PM

Libre Office 'save as' window too large on HP laptop
 
I am running Bodhi Linux 5.0.0 with Moksha Desktop 0.3.0 on a HP laptop. Whenever I use Libre Office, the 'save as' screen is taller than my screen. I can adjust the width of the screen, however, both the top and the bottom of the window are off-screen, so the height of the window remains at 885 pixels. The main controls of the 'save as' window are off-screen. The window remains open until I hit the 'esc' key. To add to my confusion, there does not appear to be a way to adjust my screen resolution.

frankbell 08-17-2019 10:12 PM

Point the mouse at the "Save as" window and hold down the ALT key. You should be able to move the window around until you can see the "handles" to adjust its size and/or click the buttons you need the click.

What screen resolution is in use?

And welcome to LQ.

AntonyFromWatertown 08-17-2019 10:28 PM

Many thanks. That solved my initial problem. However, My secondary question about screen resolution remains. I can't find anything under Settings where I can view or adjust screen resolution.

frankbell 08-17-2019 10:36 PM

I've never used Bohdi, but this article looks like it might help: https://www.bodhilinux.com/w/configu...-bodhi-system/

ondoho 08-18-2019 04:05 AM

Counterintuitively, maximising the window also helps.

What is the native resolution of your laptop's screen?

Output of
Code:

xrandr
lspci -k | grep -iEA5 'vga|3d|display'

please.

mrmazda 08-18-2019 04:52 AM

Output from
Code:

inxi -GxxSM
will also tell us something useful about your particular laptop and X configuration, if you have inxi installed.

fatmac 08-18-2019 07:20 AM

As above, just 'maximise' your application & it will fit your screen. :)

(Hold down Alt key & your left mouse button, & you should be able to drag an oversized screen into view.)

AntonyFromWatertown 08-20-2019 12:57 AM

Quote:

Originally Posted by ondoho (Post 6026350)
Counterintuitively, maximising the window also helps.

What is the native resolution of your laptop's screen?

Output of
Code:

xrandr
lspci -k | grep -iEA5 'vga|3d|display'

please.

Code:

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8210]
        Subsystem: Hewlett-Packard Company Kabini [Radeon HD 8210]
        Kernel driver in use: radeon
        Kernel modules: radeon, amdgpu
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio
        Subsystem: Hewlett-Packard Company Kabini HDMI/DP Audio


AntonyFromWatertown 08-20-2019 01:05 AM

Quote:

Originally Posted by mrmazda (Post 6026361)
Output from
Code:

inxi -GxxSM
will also tell us something useful about your particular laptop and X configuration, if you have inxi installed.

Code:

System:    Host: bodhi-HP-15-Notebook-PC Kernel: 4.15.0-20-generic x86_64
          bits: 64 gcc: 7.3.0
          Desktop: Enlightenment 0.3.0.16232 dm: lightdm
          Distro: Ubuntu 18.04.3 LTS
Machine:  Device: laptop System: Hewlett-Packard product: HP 15 Notebook PC v: 096C100002405E00050660180 serial: N/A
          Mobo: Hewlett-Packard model: 2330 v: 99.0B serial: N/A
          UEFI: Insyde v: F.13 date: 08/29/2014
          Chassis: type: 10 serial: N/A
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8210]
          bus-ID: 00:01.0 chip-ID: 1002:9834
          Display Server: x11 (X.Org 1.19.6 )
          drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
          Resolution: 1366x768@60.02hz
          OpenGL: renderer: AMD KABINI (DRM 2.50.0, 4.15.0-20-generic, LLVM 8.0.0)
          version: 4.5 Mesa 19.0.8 Direct Render: Yes


mrmazda 08-20-2019 01:58 AM

AntonyFromWatertown, you neglected two things:
  • xrandr output
  • wrapping output of the commands in code tags, which maintains the output format and legibility of monospaced type
I suspect 1366x768 is the preferred mode of your display, which probably means a higher mode will not be possible. Xrandr output should clear that up. A save as window taller than the available space within which to fit is almost certainly a software defect, a bug.

AntonyFromWatertown 08-20-2019 02:05 AM

Quote:

Originally Posted by mrmazda (Post 6027115)
AntonyFromWatertown, you neglected two things:
  • xrandr output
  • wrapping output of the commands in code tags, which maintains the output format and legibility of monospaced type
I suspect 1366x768 is the preferred mode of your display, which probably means a higher mode will not be possible. Xrandr output should clear that up. A save as window taller than the available space within which to fit is almost certainly a software defect, a bug.

Code:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
LVDS connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
  1366x768      60.02*+  40.01
  1280x720      59.97
  1152x768      59.95
  1024x768      59.95
  800x600      59.96
  848x480      59.94
  720x480      59.94
  640x480      59.94
HDMI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)


ondoho 08-20-2019 03:01 AM

Quote:

Originally Posted by AntonyFromWatertown (Post 6027102)
Code:

Resolution: 1366x768@60.02hz

That seems to be it then.
You can confirm with 'xrandr' if you want to.

mrmazda 08-20-2019 03:17 AM

Quote:

Originally Posted by AntonyFromWatertown (Post 6027117)
Code:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
LVDS connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
  1366x768      60.02*+  40.01


The * indicates the current mode. The + indicates the display's preferred mode. Lack of any higher mode than 1366x768 listed indicates no higher mode is reported by EDID to be supported by the display.

mrmazda 08-20-2019 03:51 AM

LibreOffice has a lot of settings customizations possible. Maybe you can find one that affects or selects file picker or its behavior.

https://ask.libreoffice.org/en/quest...big-for-frame/
https://ask.libreoffice.org/en/quest...r-libreoffice/
https://askubuntu.com/questions/9637...e-them-smaller
all suggest interesting possibilities.

Another: try switching the integration package. If using libreoffice-gtk3, try libreoffice-kde4 or vice versa, or libreoffice-gnome, or libreoffice-gtk2. Moksha may need a different one than whatever defaults.

ondoho 08-20-2019 01:00 PM

Quote:

Originally Posted by ondoho (Post 6027134)
That seems to be it then.
You can confirm with 'xrandr' if you want to.

Not sure what happened there, I'm pretty sure the xrandr output wasn't there when I wrote this.
Maybe I really forgot to hit F5 for almost an hour?

Anyhow:

That seems to be it then. That's the highest resolution available.


All times are GMT -5. The time now is 09:56 PM.