LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   libpng-1.6 and libpng-1.2 + python problems (https://www.linuxquestions.org/questions/linux-software-2/libpng-1-6-and-libpng-1-2-python-problems-4175586435/)

n4rf 08-06-2016 12:19 PM

libpng-1.6 and libpng-1.2 + python problems
 
Hi, im currently working on a project wich involves some imaging processing involving opencv.

The main issue, is that I need to output the result as a PNG file.

Im currently on Slackware64 14.2 (multilib) + python2.7 ..

Everytime I run my code this warning shows up:

"libpng warning: Application built with libpng-1.2.56 but running with 1.6.23"

Thus no PNG file is created...

Of course, if I change to JPG.. It works.. but that file is pretty much useless to me.

I've manually downloaded + compiled + installed libpng12 .. but still havent been able to make it work.

Suggestions are welcome.

PS: I havent been able to use Kingsoft WPS Office either. Ive created symbolic links. but still... PNG12 error

business_kid 08-06-2016 12:28 PM

Have you got libpng-1.2.56 & do the symlinks libpng.so, & libpng.so.1 point to it? Where is libpng-1.6x? Do you need it?
Can you isolate what exactly is bellyaching about libpng versions?

n4rf 08-06-2016 01:04 PM

Ive uninstalled libpng1.6.x...

If I run:

[n4rf@ASUS ~]$ libpng-config --version
1.2.56

I guess, I have to uninstall, and recompile, reinstall opencv.. will give it a shot...

n4rf 08-06-2016 01:54 PM

Ok, I will tag this as solved.

Uninstalled libpng1.6.x... uninstalled opencv... (previously installed libpng1.2.56).. Recompiled, reinstalled OpenCV..

PNG file created successfully :)


Ty business_kid


All times are GMT -5. The time now is 01:58 PM.