-   Linux - Software (
-   - failure upgrading to mysql 4 (

raj000 01-04-2006 07:36 AM failure upgrading to mysql 4
Hi Guys...

I using Fedora Core and recently tried to upgrade MySQL v3.23 to MySQL ver 4.1.16

I first un-installed the previous MySQL version comletely. While doing this, Since it was warning me about certain applications that were depending upon MySQL 3.23 , i like a fool un-installed those applications as well before proceeding. I don't think i un-installed anything of major importance except php-mysql. Following is from my command history while i was doing this

826 rpm -qa |grep sql
827 rpm -e mysql-server-3.23.58-4
828 rpm -e mysql-3.23.58-4
829 rpm -e php-mysql-4.3.8-1.1
830 rpm mod_auth_mysql-20030510-3
831 rpm -e mod_auth_mysql-20030510-3
832 rpm -qa |grep sql
833 rpm -e mysql-3.23.58-4
834 rpm -e perl-DBD-MySQL-2.9002-1
835 rpm -e mysql-3.23.58-4
836 man rpm
837 rpm -e --nodeps mysql-3.23.58-4
838 rpm -e perl-DBD-MySQL-2.9002-1

Now i installed mysql 4.1.16 and to ensure everything goes smoothly, pretty much installed all there was to install :)

I used rpm -ivh *My*

MySQL-bench-4.1.16-1.glibc23.i386.rpm MySQL-ndb-management-4.1.16-1.glibc23.i386.rpm
MySQL-client-4.1.16-1.glibc23.i386.rpm MySQL-ndb-storage-4.1.16-1.glibc23.i386.rpm
MySQL-debuginfo-4.1.16-1.glibc23.i386.rpm MySQL-ndb-tools-4.1.16-1.glibc23.i386.rpm
MySQL-devel-4.1.16-1.glibc23.i386.rpm MySQL-server-4.1.16-1.glibc23.i386.rpm
MySQL-embedded-4.1.16-1.glibc23.i386.rpm MySQL-shared-4.1.16-1.glibc23.i386.rpm

So now MySQL and php are working fine independantly. However, since i un-installed php-mysql-4.3.8-1.1 , i think php does not have mysql support.

I tried to re-install php-mysql using yum , but it gives a dependancy error -:
Resolving dependencies
....identical dependency loop exceeded
package php-mysql needs (not provided)

I did a search for this on my machine and got the following -:

[root@development root]# locate sqlclient

How do i make php work with mysql now...please help.

megaspaz 01-04-2006 11:49 AM

install the shared-compat package and you should be golden. FYI if you install the shared-compat package you don't need to install the shared library package as the shared-compat package installs the libraries from the shared library package as well as the *.so.10 library. Also, you won't have any dependency issues with programs you've installed - you won't have to uninstall stuff like you did at first.

raj000 01-06-2006 07:18 AM worked worked...

raj000 01-06-2006 07:22 AM

one more thing
ok...i am gonna repeat the same procedure on an identical ... this time live server.

As per your suggestions, i will not un-install anything other than mysql-server 3.23 .

Then i will look for an installed mysql-shared ... if there is any, i will first un-install this....then install mysql-compat and then install mysql v 4.1.16

am i correct ?

megaspaz 01-07-2006 06:29 AM

I would uninstall any installed mysql-shared package, and then upgrade everything in one go (including the mysql-shared-compat package). But this is because I use an rpm distro where I can use the -U flag.

If you're going from version 3.X to 4.X and greater, you better read the upgrading notes on mysql's website. There's quite a few things that are not compatible between versions.

All times are GMT -5. The time now is 09:45 AM.