LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-30-2018, 08:59 AM   #1
mariojuniorjp
LQ Newbie
 
Registered: Feb 2018
Posts: 3

Rep: Reputation: Disabled
libinput can't compile on Crux 3.3. Error on linking libinput.so.10.13.0.


Hey, folks! How is going?

So, i having a little trouble with libinput on Crux. I trying to compile for Plasma and Nvidia drivers, but i get this error:

Code:
[27/40] Linking target libinput.so.10.13.0.
FAILED: libinput.so.10.13.0
Here the log: https://pastebin.com/Vx8hz9aN

Here the Pkgfile: https://pastebin.com/s8kyhJyX

I tried to find something on Google that would help me clarify the problem, but I could not find anything.

Thanks you in advance!

EDIT: problem solved. I just run "prt-get sysup" again and libinput as compiled and installed without errors.

Last edited by mariojuniorjp; 03-30-2018 at 11:57 AM.
 
Old 03-31-2018, 06:43 AM   #2
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010
Look here
Quote:
input@sha/src_evdev.c.o: In function `evdev_device_create':
/usr/ports/work/libinput/src/libinput-1.10.3/build/../src/evdev.c:1960: undefined reference to `libevdev_set_device_log_function'
So, unless you can find the problem with the code, you'll have to make a bug report. You might want to make sure your using the latest compiler.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Finally decided to try to get libinput to work Timothy Miller Linux - Hardware 3 01-04-2018 08:04 PM
Libinput questions... Timothy Miller Linux - Laptop and Netbook 5 11-25-2017 03:33 AM
[SOLVED] Libinput - beware! pchristy Slackware 12 01-20-2017 02:46 PM
why slackware no have xf86-input-libinput ? USUARIONUEVO Slackware 9 03-13-2016 08:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration