LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-26-2005, 01:03 PM   #1
sina_kish
LQ Newbie
 
Registered: Jan 2005
Location: Sweden
Distribution: SuSE
Posts: 15

Rep: Reputation: 0
libgnome-devel bug!!


recently I started to learn programming GNOME/GTK+

GTK+ libraries in my SuSe Linux 9.3 are ok. But when I tried programming
with gnome library (libgnome-devel and libgnomeui-devel ), although I have
installed development packages and header files correctly (pkg-config libgnome-2.0 shows correct pathes) but I receive an error saying that file
"popt.h" that is referred from another header file ( I forgot it's name. sorry)
is missing. and because of that missing header file, compiler sees a syntax error
that is caused by string "poptContext" ( which is probably a macro or typedef in popt.h).

I haven't found anything on net about this yet. I also downloaded both the above packages and they too have the same problem.

any help is much appreciated.

thank you
 
Old 10-28-2005, 04:07 AM   #2
mr_demilord
Member
 
Registered: Sep 2005
Posts: 244

Rep: Reputation: 30
Maybe you have libpopt on your system, but not popt.h? If so, you
should probably configure --with-included-popt.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
evolution-2.2.1.1 missing libgnome.so EAST&WEST Linux - Software 0 06-08-2005 09:34 AM
help with library libgnome-keyring.so.0 Slackeriz Slackware 2 04-17-2005 06:12 AM
Package fam-devel needs libselinux-devel belkins Linux - Newbie 2 10-18-2004 04:02 PM
mplayer and gtk-devel and libpng-devel ... purpleburple Linux - Software 1 03-16-2003 04:57 AM
Possible bug in glibc-devel-2.2.93-5 and glibc-devel-2.2.5 mark_umr Linux - Software 1 10-22-2002 02:28 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration