LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-04-2017, 03:12 PM   #1
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, EndeavourOS
Posts: 3,663
Blog Entries: 7

Rep: Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298
LFTP options


So, I'm trying to ftp some files to a client. We'll be automating the transfers via a simple cron job, so it requires a command line ftp client. I've set up filezilla to verify that the connections work and the username/password has the correct authorization, and am trying to get lftp to work also. The problem I'm running into is that I have no idea how to set up the connection with lftp. In Filezilla, I had to set it to force passive mode (instead of "default") and choose "Require explicit FTP over TLS" for encryption in order to connect. In /etc/lftp.conf, I've tried setting


set ftp:ssl-auth TLS
set ftp:ssl-force yes
set ftp:ssl-protect-list yes

But still can't transfer files or even do an ls. Any ideas of what the lftp equivalent of Require explicit FTP over TLS is?

LFTP | Version 4.4.8 | Copyright (c) 1996-2013 Alexander V. Lukyano
on CentOS 7 fully updated.

[code]

Last edited by Timothy Miller; 04-04-2017 at 05:20 PM.
 
Old 04-04-2017, 05:11 PM   #2
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, EndeavourOS
Posts: 3,663

Original Poster
Blog Entries: 7

Rep: Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298Reputation: 1298
I think I got it!!

Ended up I needed my lftp.conf settings to have

Code:
set ftp:ssl-allow yes
set ftp:ssl-auth TLS
set ftp:ssl-force yes
set ssl:verify-certificate no
set ftp:ssl-protect-data yes
set ftp:ssl-protect-list yes
And I needed to FORCE the port to stay on 21 (even though ftps is usually on 990).

Last edited by Timothy Miller; 04-04-2017 at 05:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lftp no empty directory options does not work ra93013 Linux - Software 0 01-13-2015 09:48 PM
Proper make options and gcc options for my particular processor CyclicFlux Linux - General 1 08-17-2012 07:49 PM
How do I delete KDE options without deleting Dolphin's options? Mr. Alex Linux - Software 1 10-27-2011 06:06 AM
lftp mikeshn Linux - Software 11 07-20-2011 12:44 PM
[SOLVED] modifying stream id of ip options Error options (unknown 136) MegaMindd Programming 0 06-07-2011 09:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration