LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-30-2019, 12:54 AM   #1
Rakesh6650
LQ Newbie
 
Registered: Jul 2019
Posts: 1

Rep: Reputation: Disabled
Lftp not working with TLS


I am trying to connect to an external website using LFTP and am receiving the TLS handshake error. Please see the below logs. Any help would be really appreciated.

[root@usg001 .history]# lftp -e "set ftp:ssl-auth TLS;set ftp:ssl-force true;set ftp:ssl-protect-data true;" ftpssl.rbc.com -p 20021 -d
lftp ftpssl.rbc.com:~> User TESTT2X0
Password:
lftp TESTT2X0@ftpssl.rbc.com:~> dir
---- Connecting to ftpssl.rbc.com (142.245.46.80) port 20021
<--- 220 RBCNG FTPS (Version Mon Jul 29 11:17:57 2019) server ready.
---> FEAT
<--- 530 Login with USER first.
---> AUTH TLS
<--- 234 Enabling TLS, awaiting negotiations.
---> USER TESTT2X0
**** gnutls_handshake: A TLS packet with unexpected length was received.
---- Closing control socket
ls: Fatal error: gnutls_handshake: A TLS packet with unexpected length was received.
lftp TESTT2X0@ftpssl.rbc.com:~>
 
Old 07-30-2019, 03:50 AM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 13,188

Rep: Reputation: 4181Reputation: 4181Reputation: 4181Reputation: 4181Reputation: 4181Reputation: 4181Reputation: 4181Reputation: 4181Reputation: 4181Reputation: 4181Reputation: 4181
probably this helps a bit: https://stackoverflow.com/questions/...h-was-received
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] NSS LDAPS (TLS) not working. LDAP (non-TLS) is working LBM Linux - Server 4 11-05-2013 12:22 PM
[SOLVED] Centos 6.4 with OpenLDAP+TLS: OpenLDAP ok, add TLS =>not ok chrism01 Linux - Server 2 10-27-2013 04:15 PM
why do some mail servers send me email w/TLS and others not,even though i enable TLS? psycroptic Linux - Server 10 10-01-2013 04:20 PM
lftp - setting tls for data connection womd Linux - Newbie 1 10-22-2008 06:44 AM
errno: TLS definition in /lib64/libc.so.6 section .tbss mismatches non-TLS reference johnpaulodonnell Programming 2 07-25-2008 05:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration