-   Linux - Software (
-   -   lftp mirror problem (

crusher88 08-12-2009 05:18 AM

lftp mirror problem
I'm using lftp mirror to copy my local files to a remote ftp-server.

The command is:

lftp -e "mirror --continue --verbose=3 --only-newer --reverse --log=/logfile.log /local/dir /remote/dir"
Everytime I run this command, there are always four files that are not transferred.
The debug log shows this for the four files:


---> PASV
<--- 227 Entering Passive Mode (38,99,42,154,194,231)
---- Connecting data socket to ( port 49895
---- Data connection established
---> ALLO 264642
<--- 200 OK
---> STOR RIMG0026.JPG
<--- 150 Opening BINARY mode data connection for file RIMG0026.JPG.
<--- 425 Can't open data connection.
---- Closing data socket

Someone please advice what to do?
All other files in the local directory are transferred correctly.

It is the same result with or without the --only-newer option.

jeromeNP7 08-13-2009 08:09 AM

Can it be that those image files are unusally large? Maybe there is some limit on the max. amount of a single file or some other quota setting not even related to the ftp server. Are those problem valid images for sure? Difficult to say what it is, the error feedback from the ftp server is not truly helpful.


crusher88 08-14-2009 01:03 AM

Well, I've been testing a little more:

I made another copy of one of the files, and now it's just the new copy that doesn't work.

I also added another subdirectory containing some files, and now there's only one file in the subdirectory that doesn't come over.

Seems a little strange to me?

Oh... and everything works just fine when connecting to another ftp-server.

All times are GMT -5. The time now is 04:53 AM.