-   Linux - Software (
-   -   LDAP TLS lockups (

blueplazma 04-21-2005 05:52 PM

LDAP TLS lockups
Here's my problem. I'm running OpenLDAP on an Ubuntu Hoary machine. Everything works fine when I'm not using TLS. When I try to use TLS, the LDAP server grinds to a halt and always leaves this error:

Apr 21 18:46:47 localhost slapd[4097]: ber_get_next on fd 10 failed errno=11 (Resource temporarily unavailable)
I get the same error sometimes while running without TLS, but LDAP seems able to just continue on with no problem. Is this related to TLS at all? I'm very confused because TLS always crashes the LDAP server and I have no idea why. Does anyone have any ideas? Thank you.

twsnnva 04-23-2005 01:45 PM

Have you tried using LDAP over SSL (ldaps://) instead of TLS? Can you post your slapd.conf? I would also suggest that you post on the OpenLDAP mailing lists.

blueplazma 04-23-2005 01:48 PM

Yah. I got ldaps working, so I'm straightened out I think. Thanks.

All times are GMT -5. The time now is 07:00 PM.