LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-03-2004, 06:19 PM   #1
DC_Tsunami
LQ Newbie
 
Registered: Sep 2003
Location: Pasadena, CA
Distribution: Debian
Posts: 5

Rep: Reputation: 0
Question kword spellcheck


I'm having a few problems using the spell check in KWord. Maybe someone else has had this problem and can offer some insight.

I configured the spellcheck on the spelling page of "Configure KWord." I'm using the ASpell client and the English dictionary with US-ASCII encoding. The problem is that when I actually perform the spell check, it goes really slowly and eats all of my CPU time. Sometimes it just appears to hang. Also the autospellcheck isn't working (isn't it supposed to underline misspelled words as you type them like in other word processors?).

I tried changing the client to ISpell, but when I do that, it just zips through the whole document, skipping all the words (it shows a dialog with each misspelled word for a fraction of a section). And the autospellcheck still doesn't work.

So one's too way too fast and one's way too slow. I'm looking for something in between here. Is there an Espell or something like that (ha ha)? Any thoughts?

Thanks in advance.

Last edited by DC_Tsunami; 03-03-2004 at 06:27 PM.
 
Old 03-03-2004, 06:23 PM   #2
contrasutra
LQ Guru
 
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 47
What problems? For people to help you, be as specific as possible.
 
Old 03-24-2004, 06:58 PM   #3
meldroc
Member
 
Registered: Aug 2003
Posts: 102

Rep: Reputation: 15
I'm getting similar problems. I'm using KDE 3.2.1, with KOffice 1.3, from the Debian Sid packages. I've also tried both ISpell and ASpell, with similar results as DC_Tsunami. The spell-check component for KDE in general works fine - it's highlighting words it doesn't know about in this post I'm typing in Konqueror. I checked it's configuration: International ISpell, US-ASCII, American English. No problems there. I tried the exact same options in KWord, but I get no highlights of misspellings, even though I have the option "Show misspelled words in document" enabled, and so on. If I click Tools -> Spellcheck -> Spelling... I see the spellcheck dialog flicker on the screen for a fraction of a second, then disappear repeatedly, showing various words it found in the document (meaning the spell checker is working OK, just the interface with KWord is broken.)

If anybody knows how to fix this, I'd appreciate it.
 
Old 03-29-2004, 04:39 PM   #4
The_Mule
LQ Newbie
 
Registered: Mar 2004
Posts: 1

Rep: Reputation: 0
re: kword spellcheck

I'm having the exact same problem as described here. KDE Libs 3.2.1 and KWord 1.3. Spelling errors are not indicated, and running spell check eats 100% of the cpu. If I leave it alone for a minute it will then bring up the dialog to fix errors, but not everyone using the system will be as patient as me

I've only just installed KOffice today and havn't taken the time to look into this in any detail. I'll post anything I find in the future. Just wanted to get the word out that this is not an isolated thing.

Regards
 
Old 04-07-2004, 02:23 AM   #5
AdamJuel
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Rep: Reputation: 0
Having this problem also

I am also having the same problem. I don't want this thread to die off because I absolutely love KWORD over OpenOffice, its an incredible little program.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SpellCheck Module [PX]Kal Bob LQ Suggestions & Feedback 1 04-18-2004 02:10 AM
can't spellcheck in OpenOffice hobylinux Linux - Software 6 10-11-2003 12:15 PM
No spellcheck in OpenOffice frkstein Linux - Software 2 09-04-2003 01:51 PM
SpellCheck tarballedtux LQ Suggestions & Feedback 1 04-05-2002 08:44 AM
Spellcheck jeremy LQ Suggestions & Feedback 1 09-17-2001 02:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration