LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-30-2018, 04:56 PM   #1
Crotalid
Member
 
Registered: Jan 2006
Location: Carmichael, California
Distribution: Kubuntu 19.04
Posts: 68

Rep: Reputation: 19
Kubuntu 18.10: mixer is defaulting to stereo headphones on bootup


I am having an issue in Kubuntu 18.10, where my ALSA mixer is defaulting to the stereo headphones setting (under analog output), where I want it set to multichannel.
Unfortunately if it's set to stereo headphones, my speakers are mute.

This happens every time I boot up. I either use QasMixer or the command-line alsamixer to fix it. It's annoying, but not a huge deal. Still, I'd like to know how to make the mixer's settings "stick".

I've never actually had this problem before. Although I had to use QasMixer (or alsamixer) to initially set up my speakers, the settings always stuck before.
Not this time, it seems.

Is there some way to set ALSA to default to multichannel?

Last edited by Crotalid; 12-30-2018 at 05:02 PM.
 
Old 12-31-2018, 06:34 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
I think you should be able to tweak the .asoundrc config file for multichannel settings.
See the link below.

By default, Linux applications will send audio directly to one specific device. All you need is a properly structured ~/.asoundrc file to configure ALSA.

http://www.6by9.net/output-to-multip...ces-with-alsa/

http://alsa-project.org/main/index.p...hannel_devices

Hope that helps.
 
Old 12-31-2018, 08:09 PM   #3
Crotalid
Member
 
Registered: Jan 2006
Location: Carmichael, California
Distribution: Kubuntu 19.04
Posts: 68

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by Ztcoracat View Post
I think you should be able to tweak the .asoundrc config file for multichannel settings.
See the link below.

By default, Linux applications will send audio directly to one specific device. All you need is a properly structured ~/.asoundrc file to configure ALSA.

http://www.6by9.net/output-to-multip...ces-with-alsa/

http://alsa-project.org/main/index.p...hannel_devices

Hope that helps.
I've read about the .asoundrc file, but I still don't know how to set it to switch to Multichannel Analog Output. I don't see anything in those sites that explains how to just set the output to Multichannel. Most of it seems to be about using 2 cards at once, which isn't what I'm doing.

I don't know how to control the mixer with the .asoundrc file. That is the only thing that's wrong... once I switch it to multichannel, it works just fine.
 
1 members found this post helpful.
Old 12-31-2018, 08:47 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
That is the only thing that's wrong... once I switch it to multichannel, it works just fine.
How are you switching it to multichannel exactly?

------------------------------------**********************------------------------------------------
You might have to install Pulse Audio to be able to set it to multichannel analog output.
Most Linux distros use Pulse Audio now.

Last edited by Ztcoracat; 12-31-2018 at 08:56 PM.
 
Old 12-31-2018, 09:10 PM   #5
Crotalid
Member
 
Registered: Jan 2006
Location: Carmichael, California
Distribution: Kubuntu 19.04
Posts: 68

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by Ztcoracat View Post
How are you switching it to multichannel exactly?

------------------------------------**********************------------------------------------------
You might have to install Pulse Audio to be able to set it to multichannel analog output.
Most Linux distros use Pulse Audio now.
I'm setting it with QasMixer or the command-line alsamixer. I do have Pulse Audio installed though.
 
Old 12-31-2018, 09:23 PM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by Crotalid View Post
I'm setting it with QasMixer or the command-line alsamixer. I do have Pulse Audio installed though.
I'm not familiar with QasMixer.

Try opening Pulse Audio and go to > Configuration.
Under configuration you should see 'profile' with a drop down menu.
***Before going through the list in the drop down menu remember what it's set to.***

In the drop down list look and see if you can set it to multichannel analog output.
What sound card do you have?

Set the default output source
https://wiki.archlinux.org/index.php...Audio/Examples
 
Old 12-31-2018, 09:41 PM   #7
Crotalid
Member
 
Registered: Jan 2006
Location: Carmichael, California
Distribution: Kubuntu 19.04
Posts: 68

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by Ztcoracat View Post
I'm not familiar with QasMixer.

Try opening Pulse Audio and go to > Configuration.
Under configuration you should see 'profile' with a drop down menu.
***Before going through the list in the drop down menu remember what it's set to.***

In the drop down list look and see if you can set it to multichannel analog output.
What sound card do you have?

Set the default output source
https://wiki.archlinux.org/index.php...Audio/Examples
I'm using an ASUS Xonar DGX (CMI8788). The profile is set to Analog Surround 5.1 Output + Digital Stereo (IEC958).
There are other options including Analog Surround Output (without the Digital Stereo part).

I also have the output on my NVidia 1080 Ti, the GP102 HDMI Audio Controller, but it's shut off since I use my soundcard.

Should I be using the profile without the digital output?



*edit: I went and reset my system. The same thing happens. The profile is still Analog Surround 5.1 Output (which I switched to before rebooting). I don't think this has to do with the Pulse Audio settings, it's somehow defaulting back to Stereo Headphones every time, and when it's set that way, my speakers are mute.

Last edited by Crotalid; 12-31-2018 at 10:05 PM.
 
Old 12-31-2018, 10:24 PM   #8
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Should I be using the profile without the digital output?
No, I don't think so-

Quote:
it's somehow defaulting back to Stereo Headphones every time,
That's annoying:-And sounds like a bug:-

If I find a way to change the default I'll let you know. So far I'm not getting anywhere with Google but I'll keep looking.

Last edited by Ztcoracat; 12-31-2018 at 10:41 PM.
 
Old 12-31-2018, 11:12 PM   #9
Crotalid
Member
 
Registered: Jan 2006
Location: Carmichael, California
Distribution: Kubuntu 19.04
Posts: 68

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by Ztcoracat View Post
No, I don't think so-



That's annoying:-

If I find a way to change the default I'll let you know. So far I'm not getting anywhere with Google:-
Thanks. I was looking through the webpages on the .asoundrc file, but I can't seem to find anything that refers to the mixer Analog Output per se. Most of it is for setting up multichannel systems, but my multichannel card works fine out of the box as-is.
 
Old 12-31-2018, 11:20 PM   #10
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
You're Welcome.

I'm finding threads where others have the same thing going on as you.....just haven't found a solution yet.

This member used something called hdajackretask.

https://ubuntu-mate.community/t/puls...t-stay/16452/2

There's got to be a way to change the default. It's getting late. I'll look more tomorrow.-

Happy New Year!
 
Old 01-01-2019, 02:58 PM   #11
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
When I was running Manjaro I had a sound bug.

No matter what I tried Pulse Audio defaulted to a setting in the configuration profile that made it so that I didn't have sound at all.
Every time I wanted to listen to music or watch a video I had to go into the Configuration and change it to 'Analog Stereo Duplex'.
No matter what I tried, (including editing the audio config file) it didn't stick.

The kind of behavior that you are explaining sounds like a bug.

This was the only fix that I was able to find. I hope it works for you.-
https://unix.stackexchange.com/quest...for-pulseaudio
 
Old 01-01-2019, 08:20 PM   #12
Crotalid
Member
 
Registered: Jan 2006
Location: Carmichael, California
Distribution: Kubuntu 19.04
Posts: 68

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by Ztcoracat View Post
When I was running Manjaro I had a sound bug.

No matter what I tried Pulse Audio defaulted to a setting in the configuration profile that made it so that I didn't have sound at all.
Every time I wanted to listen to music or watch a video I had to go into the Configuration and change it to 'Analog Stereo Duplex'.
No matter what I tried, (including editing the audio config file) it didn't stick.

The kind of behavior that you are explaining sounds like a bug.

This was the only fix that I was able to find. I hope it works for you.-
https://unix.stackexchange.com/quest...for-pulseaudio
Unfortunately, no, it didn't work. I set the parameter using "set-card-profile 0 analog-surround-51", adding it to my /etc/pulse/default.pa file. It didn't make any difference, ALSA still defaulted to Stereo Headphones FP on boot.

Worse, now my system has no sound at all, even after switching to multichannel. My audio volume tray icon says "No output or input devices found". I did manage to get Audacious to play music by setting my PCM device (under ALSA settings) to "sysdefault:CARD=DGX - Xonar DGX, Multichannel Default Audio Device", though. But other than that, my system can't find the sound server now, and my Audio Playback list (in Phonon Audio and Video) only lists "Default" instead of my usual list (both the Xonar DGX and my Nvidia card audio). Default doesn't do a thing, even when tested. It's useless.

I'll have to go and remove that line from the /etc/pulse/default.pa file.

I'm going to need to find an ALSA forum I guess, and ask there.

Thanks for the info though, even if it didn't work...

*edit: Apparently my sound does work after all. Even though the audio volume icon on my tray has no sliders and reports no devices, I can still get sound. I tried going to Youtube and the videos play audio normally. All this, despite the system not finding the devices, and my audio settings only showing "Default".

Last edited by Crotalid; 01-01-2019 at 08:25 PM.
 
Old 01-01-2019, 09:28 PM   #13
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by Crotalid View Post
Unfortunately, no, it didn't work. I set the parameter using "set-card-profile 0 analog-surround-51", adding it to my /etc/pulse/default.pa file. It didn't make any difference, ALSA still defaulted to Stereo Headphones FP on boot.

Worse, now my system has no sound at all, even after switching to multichannel. My audio volume tray icon says "No output or input devices found". I did manage to get Audacious to play music by setting my PCM device (under ALSA settings) to "sysdefault:CARD=DGX - Xonar DGX, Multichannel Default Audio Device", though. But other than that, my system can't find the sound server now, and my Audio Playback list (in Phonon Audio and Video) only lists "Default" instead of my usual list (both the Xonar DGX and my Nvidia card audio). Default doesn't do a thing, even when tested. It's useless.

I'll have to go and remove that line from the /etc/pulse/default.pa file.

I'm going to need to find an ALSA forum I guess, and ask there.

Thanks for the info though, even if it didn't work...

*edit: Apparently my sound does work after all. Even though the audio volume icon on my tray has no sliders and reports no devices, I can still get sound. I tried going to Youtube and the videos play audio normally. All this, despite the system not finding the devices, and my audio settings only showing "Default".
What changed that you have sound now?

When you first installed Kubuntu did you have this issue?
 
Old 01-02-2019, 08:48 PM   #14
Crotalid
Member
 
Registered: Jan 2006
Location: Carmichael, California
Distribution: Kubuntu 19.04
Posts: 68

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by Ztcoracat View Post
What changed that you have sound now?

When you first installed Kubuntu did you have this issue?
I didn't really change anything, aside from going back to my older settings, by deleting that line in the .asoundrc. Once I did that, I was able to get sound again, albeit only after manually switching to Multichannel in alsamixer.

And yeah, I did have this issue when I first installed Kubuntu 18.10. At least, I did on this new machine I just built. It's a Ryzen 7 2700X on an MSI X470 Gaming Plus, with 32GB (16x2) of G.Skill Ripjaws 3200MHz RAM, with a 2TB Samsung EVO 970 SSD. That, and an MSI 1080 Ti along with a few hard drives and my Xonar DGX sound card from my previous FX-8350 machine.

However, I didn't have this issue on the FX-8350 build. I've never had any issue like this until I installed Kubuntu on this Ryzen.

Whenever I freshly installed Kubuntu I needed to use QasMixer to set my Analog Output to multichannel, because it always defaulted to Stereo Headphones FP, muting the speakers.
But once I did that, it always saved the settings, and never reverted back to Stereo Headphones mode. This isn't the case with my new machine and I dunno why.

I'm probably going to have to find an ALSA forum...
 
Old 01-03-2019, 07:58 PM   #15
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by Crotalid View Post
I didn't really change anything, aside from going back to my older settings, by deleting that line in the .asoundrc. Once I did that, I was able to get sound again, albeit only after manually switching to Multichannel in alsamixer.

And yeah, I did have this issue when I first installed Kubuntu 18.10. At least, I did on this new machine I just built. It's a Ryzen 7 2700X on an MSI X470 Gaming Plus, with 32GB (16x2) of G.Skill Ripjaws 3200MHz RAM, with a 2TB Samsung EVO 970 SSD. That, and an MSI 1080 Ti along with a few hard drives and my Xonar DGX sound card from my previous FX-8350 machine.

However, I didn't have this issue on the FX-8350 build. I've never had any issue like this until I installed Kubuntu on this Ryzen.

Whenever I freshly installed Kubuntu I needed to use QasMixer to set my Analog Output to multichannel, because it always defaulted to Stereo Headphones FP, muting the speakers.
But once I did that, it always saved the settings, and never reverted back to Stereo Headphones mode. This isn't the case with my new machine and I dunno why.

I'm probably going to have to find an ALSA forum...
I'm wondering if the new Ryzen Processor has anything to due with support in the kernel for sound.
-:::-Sometimes new hardware isn't supported in the kernel and it takes the devs a while to build drivers for it.-:::-

However a quick search shows that in 2017 and with kernel 4.10 the AMD Ryzen is supported with multithreading.
https://www.pcworld.com/article/3176...threading.html

Quote:
I've never had any issue like this until I installed Kubuntu on this Ryzen.
What are the folks in the Kubuntu Forum saying about this?

Maybe Ubuntu will play nicer with the AMD Ryzen processor? OR maybe try blacklisting the driver for the headphones and see if that makes any difference. Other than that I'm out of ideas.

I couldn't find an Alsa Forum but I did find the 'Advanced Linux Sound Architecture Forum' on Source Forge:-
https://sourceforge.net/p/alsa/discussion/

I also went to the AMD website and looked for a linux driver and didn't find one. I certainly tried.
https://www.amd.com/en/search?keywor...7+linux+driver

Your new build sounds like a sweet machine. Congrads.
 
  


Reply

Tags
alsa, audio, kububtu, sound mixing


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stereo bluetooth headphones vs Wired Headphones WHITE_POWER General 2 06-04-2013 04:35 PM
No headphones no speakers on alsa-mixer T61 Oneiric legrosschmoll Linux - Newbie 9 03-19-2012 11:44 AM
couldn't open mixer device /dev/sound/mixer wangcity Linux - General 8 02-01-2004 08:17 AM
Sound issue - "Couldn't open mixer device /dev/sound/mixer" zsejk Slackware 17 08-14-2003 11:20 PM
Couldn't open mixer device /dev/sound/mixer Dabria Linux - Hardware 2 07-29-2003 12:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration