LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   ksensors and libsensors.so.1 (https://www.linuxquestions.org/questions/linux-software-2/ksensors-and-libsensors-so-1-a-106226/)

abhay 10-20-2003 06:07 AM

ksensors and libsensors.so.1
 
hello all.
i have just got lm_sensors working. i can see all the results when i use "sensors" command in konsole.
also gkrellm is working fine, showing all voltages/temps properly.
so i decided to install ksensors. now there i have the problem.
i d/led a redhat rpm and did rpm2tgz and installed the package (i am on Slack 9.1) but whenever i try to start ksensors i get an error saying
error while loading shared libraries: libsensors.so.1: cannot open shared object file: No such file or directory
i searched and found that the file is provided by lm_sensors and when i did a locate libsensors.so.1, i could not find anything.
i do have libsensors.so.2 but somehow that libsensors.so.1 is missing. i don't understand that if a file is missing then how come lm_sensors and gkrellm are working?
i have tried installing from source and i get an error at the time of make which is something like this.
make[3]: /usr/lib/qt3/bin/uic: Command not found
make[3]: *** [palettecfgdesign.h] Error 127
i feel that ksensors' make is looking for "uic" in a wrong place as i have it in /usr/lib/qt/bin/uic. so now i am stumped :(
any ideas as to what i can do?
thanx for reading.

abhay 10-21-2003 03:28 AM

<bump>


All times are GMT -5. The time now is 08:32 PM.