LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-06-2021, 06:24 AM   #1
Thalassius
LQ Newbie
 
Registered: Sep 2021
Distribution: Devuan
Posts: 20

Rep: Reputation: Disabled
Unhappy Konsole (KDE) bug.


Hi!

I'm on a Debian based distro and I stumbled upon this KDE bug:
Konsole can't display non-English characters. It displays semigraphics instead.
My directories use Greek characters, so I have a problem here.

Any known workaround?
(Otherwise I have to try another desktop. I suppose).
TIA!
 
Old 12-06-2021, 06:29 AM   #2
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 3,688

Rep: Reputation: Disabled
Only Konsole? Does it mean other terminal emulators display Greek?

From the Common Issues in The Konsole Handbook:
Quote:
Some fonts might be unavailable for usage in Konsole, although they are available in other applications. That doesn't mean there is a bug in Konsole. Konsole requires monospaced fonts to provide the best visual result, so it asks Qt to only list monospaced fonts.

Starting with version 16.08 (August 2016), Konsole can be configured to allow selecting any font with the caveat that the display may not be correct.
Setting the font for Konsole is done in
Settings ‣ Edit Current Profile... ‣ Appearance ‣ Select Font...

Also check
Settings ‣ Edit Current Profile... ‣ Advanced ‣ Default character encoding

Last edited by shruggy; 12-06-2021 at 06:48 AM.
 
Old 12-06-2021, 08:26 AM   #3
Thalassius
LQ Newbie
 
Registered: Sep 2021
Distribution: Devuan
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by shruggy View Post
Only Konsole? Does it mean other terminal emulators display Greek?

From the Common Issues in The Konsole Handbook:

Setting the font for Konsole is done in
Settings ‣ Edit Current Profile... ‣ Appearance ‣ Select Font...
Indeed, I changed the default font (Hack), with another, that I know for sure it has Greek support.


Quote:
Originally Posted by shruggy View Post
Also check
Settings ‣ Edit Current Profile... ‣ Advanced ‣ Default character encoding
It has activated the Greek ISO (8859-7) and It can't be changed to Default (none selected). Other ISOs can be selected, but of course they don't help.

PS. Other terminal emulators, working properly (eg. UXterm).
Maybe switching to another one, is the solution.
 
Old 12-06-2021, 09:15 AM   #4
lvm_
Senior Member
 
Registered: Jul 2020
Posts: 1,024

Rep: Reputation: 358Reputation: 358Reputation: 358Reputation: 358
You should set character encoding to default UTF-8, not to single-byte encodings. What's you locale (LANG)? - should be el_GR.UTF-8. Hack is a unicode font and it does support Greek: https://github.com/source-foundry/Hack

https://i.imgur.com/DXxzFaU.png
 
Old 12-06-2021, 09:26 AM   #5
Thalassius
LQ Newbie
 
Registered: Sep 2021
Distribution: Devuan
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by lvm_ View Post
You should set character encoding to default UTF-8, not to single-byte encodings. What's you locale (LANG)? - should be el_GR.UTF-8.
Indeed its el_GR.UTF-8.
Ehm...I tried it through the interface, but it can;t be changed (Probably a bug).
How it can be changed to default UTF-8, not to single-byte encodings?

Quote:
Originally Posted by lvm_ View Post
Hack is a unicode font and it does support Greek: https://github.com/source-foundry/Hack

https://i.imgur.com/DXxzFaU.png
Indeed! I didn't notice and I changed it to Dejavu, just to be sure.
I rolled back to Hack.
 
Old 12-06-2021, 09:45 AM   #6
lvm_
Senior Member
 
Registered: Jul 2020
Posts: 1,024

Rep: Reputation: 358Reputation: 358Reputation: 358Reputation: 358
Konsole profiles are stored ~/.local/share/konsole, you probably should be able to change the encoding there. Never tried it myself though.
 
Old 12-06-2021, 10:23 AM   #7
Thalassius
LQ Newbie
 
Registered: Sep 2021
Distribution: Devuan
Posts: 20

Original Poster
Rep: Reputation: Disabled
I can see several options, but it doesn't seem to have a related one.
 
Old 12-06-2021, 08:05 PM   #8
Thalassius
LQ Newbie
 
Registered: Sep 2021
Distribution: Devuan
Posts: 20

Original Poster
Rep: Reputation: Disabled
Well...it seems to be, a Debian bug.
It probably is the 902299.
I don;t know if its a coincidence, but if you look at the post, the problem occurs with Greek alphabet.
Look to the end of the page, for the word "φαρμακεία". (It means pharmacies)


Anyway! I give up. I don't know a way. to fix a Debian stable bug.
I searched for Konsole's alternatives, and I found that these 2, are possibly the best candidates. Both Qt based, they're fitting nicely to the environment:

1) QTerminal (LXQt's terminal, available as a standalone package and 2) Trinity's Konsole (if you willing to add the repository and install the tdebase-trinity package (the base package of TDE)).

THANKS! Bye!!!
 
Old 12-07-2021, 02:08 AM   #9
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 3,688

Rep: Reputation: Disabled
The first post in the linked bug report gives a workaround:
Quote:
After some investigation this bug seemed to be triggered by changes made in KDE's System Settings, Regional Settings, Formats, changed the Region from Default "United States - American English (en_US)" to "Nederland - Nederlands (nl_NL)" since I wanted to use the number/date/currency/paper/unit formats of the Netherlands.

Setting it back to default "No change" and re-login and the problem in konsole is gone.
 
Old 12-07-2021, 08:38 AM   #10
Thalassius
LQ Newbie
 
Registered: Sep 2021
Distribution: Devuan
Posts: 20

Original Poster
Rep: Reputation: Disabled
Nope! Didn't help here.
 
  


Reply

Tags
konsole, utf-8


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] open Konsole after boot and login, run a command, keep Konsole open for use heronlin Linux - General 3 10-20-2014 03:01 AM
LXer: How to file bug-free bug report in KDE LXer Syndicated Linux News 0 04-06-2013 09:03 PM
Konsole always give SuperUser Konsole - can't get regular shell checkmate3001 Linux - Desktop 3 08-05-2008 10:00 AM
Slack 12: KDE Konsole taskbar bug mathia Slackware 2 09-02-2007 03:13 PM
konsole acts as "Root Konsole" ab44045 Linux - General 11 06-11-2007 05:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration