LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   konqueror not browsing web (it is not the typical file association issue) (https://www.linuxquestions.org/questions/linux-software-2/konqueror-not-browsing-web-it-is-not-the-typical-file-association-issue-287048/)

KimVette 02-06-2005 05:48 PM

konqueror not browsing web (it is not the typical file association issue)
 
I'm running kde 3.3.2 level "A" on Suse Linux 9.1

konqueror not browsing web (it's not the typical problem others have reported, er, not the typical file association cause, that is)

konqueror is not displaying web pages in a particular account. I have verified the binaries are fine by logging into another account, where it works fine and konqueror will browse the web.

I have verified the file association for text -> html are correct and that embedding is enabled, and is associated with the KTHML engine.

When I open a web page via the file system (e.g., Location, Open Location, browse to file, select foo.html) the browser will open the file just fine and will browse internal files via hyperlinks.

HOWEVER: if I try to go to a web site by specifying the http:// protocol in the location bar, the target page is loaded in FireFox (in an existing tab if it is already open). If I am browsing a site on the filesystem and click on an external link using the http:// protocol, I get a "copy file progress" dialog wyhere it is copied to /var/tmp/kdecache-kim/krun/ and then it is displayed in FireFox (usually broken at that point because relative links in the web page are now pointing to /var/tmp/(. . .)/)

The reason the issue looks different than the typical "konqueror won't display web pages" is that I can browse pages located on the filesystem successfully, plus I have verified that the file associations appear to be correct.

leonscape 02-06-2005 06:14 PM

How about the defaults in the Control Center?

Control Center->KDE Components->Component Chooser->Web Browser.

Maybe its set to Firefox instead of the default for the associations.

KimVette 02-07-2005 05:53 PM

Thanks! I actually just stumbled over that setting about 15 minutes before seeing your post and was going to post here that the issue is resolved. That's been driving me NUTS for a few weeks now because I *knew* I had the file association configured properly.

D'oh!

ugge 05-07-2005 02:52 AM

leonscape: That would possibly solve my problem. Only problem now is that I can't find Web Browser under the Copmponent Chooser.

What I try to do is to make mozilla/firefox handle all webrelated things mimetype text/html as well as register firefox/mozilla with the http:// protocol.
Any idea how I would go about it?


All times are GMT -5. The time now is 08:31 AM.