-   Linux - Software (
-   -   Konqueror and phpMyAdmin--opens in Kwrite, won't display PHP (

hindenbergbaby 10-13-2003 08:34 AM

Konqueror and phpMyAdmin--opens in Kwrite, won't display PHP
I am trying my damnedest to get phpMyAdmin to play nice with SOMETHING on my computer. I am running SuSE 8.2 and have Apache 2, PHP 4.3.3 and phpMyAdmin 2.4.0 installed. And of course, mySQL. I try to open phpMyAdmin with Konqueror, but I run into problems. First, it associated it with Kwrite, so I just got a screen full of source code. I tried to associate it with Konqueror, and now I get this message:

There appears to be a configuration error. You have associated Konqueror with text/x-c++src, but it can't handle this file type.

I also tried it with Opera, and I get some weird php output, not what it actually is supposed to be. I tried Galeon and Mozilla, too, just for the hell of it, and they give me the source code, just like Konqueror did originally (before I screwed it up, evidentally).

Any ideas what I'm doing wrong, and what I can do to get this working? Other php files (ones on the net) work okay... Keep in mind I am a complete newb. I tried searching here and Google, but alas, most people's comprehension seems a little more advanced than mine.


david_ross 10-13-2003 01:31 PM

If you ar egetting php output then it is likely to eb a server problem. Have you used php on that system before? Create a file called phpino.php and put it in the root of your web server


And access it via your webserver - do you get the code back or a list of installed php modules and a version number?

hindenbergbaby 10-13-2003 02:51 PM

Thanks for replying.

I was a little confused, so I created an actual php file (and got code back), which is what I think you meant.

I also queried info via the shell about php, and got this Status: 404
Content-type: text/html
X-Powered-BY: PHP/4.3.3

I'm not sure if that's helpful.

Here's the scoop: I don't intend on using this to do any database management on the web... I'm setting it up with the necessary files on my Linux desktop, mainly because I'm taking a database management class and I need it to do homework, not because I actually have ANY idea what I'm doing. So I installed all the parts and kind of hoped phpMyAdmin would fall into place. So please forgive me if I ask really stupid questions along the way here... I'm setting this up as localhost and going from there...

thanks again

david_ross 10-13-2003 02:55 PM

Check that you have php installed and that you have the required directives in httpd.conf. You should be ale to find these in the php documentation.

Just post if you run into problems.

hindenbergbaby 10-14-2003 01:52 PM

Hey David,

Sorry, didn't realize I posted it in another forum... must have been a couple days ago (between this and a VERY uncooperative application in Windows, I've been out straight in front of this freakin' computer), or I clicked something wrong or something...

I didn't see a loadmodule line... Honestly, I looked through httpd.conf, and googled, and saw that there should be a line that says something like AddType application/x-httpd-php, and that wasn't ANYWHERE to be seen. So I added it. I'm going to take another looksie, though. Didn't see a loadmodule line anywhere.

It looks like the more I google, the more confused I get.


david_ross 10-14-2003 02:10 PM

This is the document I was reffering to:

hindenbergbaby 10-14-2003 02:21 PM

Okay, got it... Think I may have screwed up installation, so I'm trying to reconfigure. I'll let you know how it goes. Thanks!


hindenbergbaby 10-14-2003 03:20 PM

Okay. I got this error message after I configured and ran "make" again... I figured I'd not configured with mysql or --/usr/local/apache2 so I think that might have been half my problem...

In function 'php_stat': /php4-200310141930/ext/standard/filestat.c:575: undefined reference to 'php_check_open_basedir_ex'
collect2: ld returned one exit status
make: *** [sapi/cli/php] Error 1

Any clue as to what's going on?


david_ross 10-14-2003 03:36 PM

Did you do a "make distclean" prior to recompiling or did you use the sources from scratch again?

hindenbergbaby 10-14-2003 04:38 PM

good news bad news
Well, make distclean worked (that's a handy little command... I am PAINFULLY new at Linux. Never would have guessed, huh?). I got it installed again, and LoadModule actually showed up in my Apache conf file. I added what it said to add on that link you so kindly gave...

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source

Alas, everything is still opening as if my computer's never seen php before. I have tried fiddling with the settings in Opera, adding application/x-httpd-php to Mime Types, but still no luck.

Any suggestions?


alm 10-14-2003 06:48 PM

Try changing the name of your .html file to something with a .php ending,
or have you tried this already?

hindenbergbaby 10-14-2003 07:32 PM

Better news
After some playing, I got the phpinfo script to work (yeeha). However, I still can't get phpMyAdmin to work. Does it also need to be in the Apache htdocs dir? Or is there some other configuration I can use to get it to work? I haven't seen much about this.


hindenbergbaby 10-14-2003 08:08 PM

I moved phpMyAdmin and....Okay, I got phpMyAdmin to come up (the saga continues) but I get this error message:

phpMyAdmin - Error

phpMyAdmin was unable to read your configuration file!
This might happen if php finds a parse error in it or php cannot find the file.
Please call the configuration file directly using the link below and read the php error message(s) that you receive. In most cases a quote or a semicolon is missing somewhere.
If you receive a blank page, everything is fine.

I look at the ever so descriptive, and discover that it's blank. I'm guessing that I have a link problem, but I'm not sure where. Actually, I'm not entirely sure what a parse error even is. My guess, however, is that php can't find the file. I'm assuming I link php.ini-recommended to something? Maybe? Bueller? Any suggestions will be entertained.

Thank everyone who's tried to help me. I must be driving you bats.


david_ross 10-15-2003 12:46 PM

The config file shoudln't be blank. Try downloading and unpacking again.

hindenbergbaby 10-15-2003 01:54 PM

I'm sorry, David, I was unclear with my description in what I reported earlier... I just read what I wrote again...

My has content... I get all the configuration settings and such. However, when I get the error message, it flashes a link to If I click on the link, instead of getting an error message, I just get a blank document.

The error message on index.php says if that happens, everything is fine. However, it's pretty obvious that everything isn't if I'm still getting the error message. I'm going to play with the configuration a little more... I must have something set wrong somewhere, though I don't know whether it's with phpMyAdmin or somewhere else.


Edit: Does php need a link of some sort to be able to find phpMyAdmin? Perhaps that's it?

All times are GMT -5. The time now is 02:49 AM.