LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-13-2005, 04:28 AM   #1
srivastava
LQ Newbie
 
Registered: Apr 2005
Posts: 14

Rep: Reputation: 0
KNOPPIX Live CD


My monitor does not support resolution higher than 1024x768 and I guess the default resolution for live KNOPPIX CD is higher than this. As a result, my monitor goes out of range when I insert the live CD and run KNOPPIX.

Is there anyway to overcome this problem?
 
Old 05-13-2005, 04:32 AM   #2
mithu_sree
LQ Newbie
 
Registered: May 2005
Location: /India/Kerala
Posts: 22

Rep: Reputation: 15
I also got the same problem
 
Old 05-13-2005, 08:36 AM   #3
harken
Member
 
Registered: Jan 2005
Location: Between the chair and the desk
Distribution: Debian Sarge, kernel 2.6.13
Posts: 666

Rep: Reputation: 30
I had this problem when I first used Knoppix as well. It's not the resolution, but the refresh rate which is by default too low (around 60Hz). Change it from KDE's Control Center and see if it works.
 
Old 05-13-2005, 09:58 AM   #4
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45
simple, once you boot up with knoppix and you get the flying lines across your screen (caused by the to high of an output foryour monitor) change over to one of the terminals. you will be at a root prompt and already to rock.

vim /etc/X11/XF86Config-4

then just scroll down until you start finding the res. settings in the config file. rem out (#) anything higher then your monitor can deal with, then hit the ESC and type :wq yes you need the :

after that you can either /etc/ init.d/kdm or xdm or what ever the Knoppix display is, or just init 2, then back to init 5 and you will be golden. i normally just stop X and then go back to terminal 1 and type start X after i have reconfigured the XF86Config-4 file.

I have to do that on a few of my systems even though my monitor can handle 1280x1024 it does not do so above 60Hz like the default setting in Knoppix.
 
Old 06-13-2005, 02:57 PM   #5
a1fitz
LQ Newbie
 
Registered: Jun 2005
Location: Riverton, Kansas
Distribution: knoppix
Posts: 1

Rep: Reputation: 0
Lleb_KCir

I am having what sounds like the same probelm. this is the first time to run any linux OS at all. I am going to set up my home PC with knoppix without any other OS on it. When I run this live CD everthing starts loading fine about the time the machine tells me starting desktop I have what appears like a tv with horizantal hold problems. I really didn't understand your comment on how to over come this. Probably do to my lack of understanding linux. What do you mean by change teminals. Are you saying even though I can't see the prompt I should be able to type in

vim /etc/X11/XF86Config-4

and will be able to see and work from there?
 
Old 06-13-2005, 04:38 PM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
At the boot/login prompt try typing knoppix vga=normal
you can also specify the screen size by typing knoppix screen=1280x1024(or whatever size you want)

Some of the other things you can play around with:

screen=1280x1024
Use specified Screen resolution for X

xvrefresh=60 or vsync=60
Use 60 Hz vertical refresh rate for X

xhrefresh=80 or hsync=80
Use 80 kHz horizontal refresh rate for X

xserver=XFree86|XF86_SVGA
Use specified X-Server

xmodule=ati|radeon|fbdev|vesa|savage|s3|nv|i810|mga|svga|tseng
Use specified XFree4-Module

fb1280x1024 or fb1024x768 or fb800x600
Use fixed framebuffer graphics

f you have an old (VGA) monitor and get only flickering with the defaults, try "knoppix-txt xvrefresh=60" or "fb800x600". If nothing else works, try boot: failsafe -b 1

From: Knoppix Cheat Codes

A little more up to date list of "cheat codes": CHEATCODES AND HINTS FOR KNOPPIX V3.8

Knowing Knoppix
The first guide to Knoppix for the complete beginner.

If you can spend the money and "really" want to learn some things about Knoppix and Linux get:
"Knoppix Hacks is an essential tool for anyone who works professionally or not with computers. Knoppix Hacks, just like Knoppix, is targetted at a wide audience ranging from System Administrators to the family "computer guy" called on to fix his cousin's PC.

There is a common misconception among people who have heard of Knoppix that it is only for Linux users. This perception couldn't be further from the truth. Knoppix, as demonstrated by the author, is an extremely useful tool regardless of your preferred operating system. This book is for anyone who has had to fix the computer of friends or family; the system administrator who has ever had to resuscitate a lifeless machine; even the average home user who's curious to try something new without replacing what they already have."
http://arstechnica.com/columns/linux/linux-20050504.ars

Last edited by craigevil; 06-13-2005 at 04:47 PM.
 
Old 06-14-2005, 03:49 PM   #7
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45
Quote:
Originally posted by a1fitz
Lleb_KCir

I am having what sounds like the same probelm. this is the first time to run any linux OS at all. I am going to set up my home PC with knoppix without any other OS on it. When I run this live CD everthing starts loading fine about the time the machine tells me starting desktop I have what appears like a tv with horizantal hold problems. I really didn't understand your comment on how to over come this. Probably do to my lack of understanding linux. What do you mean by change teminals. Are you saying even though I can't see the prompt I should be able to type in

vim /etc/X11/XF86Config-4

and will be able to see and work from there?
craigevil has a very detailed reply and here is a bit more if you are not willing to mess around with the multiple boots that you might have to play with to get the cheats to work.


Code:
Section "Screen"
 Identifier "Default Screen"
 Device  "Nvidia GFX 5200"
 Monitor  "Panasonic"
 DefaultDepth 24
 SubSection "Display"
  Depth  1
  Modes  "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  4
  Modes  "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  8
  Modes  "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  15
  Modes  "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  16
  Modes  "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth  24
  Modes  "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
 EndSubSection
EndSection
that is the section you are looking for inside the /etc/X11/XF86Config-4 file. you are editing with vim. vim is a text based file editor.

http://www.cs.colostate.edu/helpdocs/vi.html

http://www.cec.mtu.edu/newuserdoc/node9.html

both of those should give you enough tools to move around inside of vi (vim) to edit the above portion of the XF86Config-4 file. just scroll down until you see that part of the file. in Knoppix it is much longer so what you are looking for is to edit out the lines that start with the 1280x1024 and find the ones that start with 1024x768. then you can get back to the terminal 1 and ctrl+c to stop X from running, then type startx and X should work for you.


steps:

1. hit ctrl+alt+F2
2. type vim /etc/X11/XF86Config-4
3. scroll down until you find the lines as you see above. hit the "i" key to enter insert mode (you will see in big bold white letter INSERT in the bottom right corner of the screen) and place a # infront of the lines with the 1280x1024 as the starting resolution.
4. hit the ESC key
5. type :qw

yes that is a : then a q and a w right next to each other. this will save and exit from the file.
6. hit ctrl+alt+F1
7. hit ctrl+c (this will force stop X from running)
8. type startx (without a space between start and x)
you should be golden.

best of luck. also if you are running an ATI vid car you will want to read up on the ati hack (cheatcode) for knoppix in order to get X running too.
 
Old 06-14-2005, 05:14 PM   #8
SuSE-friend
Member
 
Registered: Jun 2005
Distribution: SuSE 9.0 / 9.1 / 9.2 - Knoppix - Ipcop.org
Posts: 31

Rep: Reputation: 15
While primary boot screen appears
hit F2 or F3
type in the "line"

knoppix screen=800x600 vsync=75

That would start Knoppix GUI - KDE with 800x600 and refreshrate 75 Hz
if that also not work try refreshrate 60Hz

and maybe experiment with higher settings ...
but your monitor is maybe limited if going to 1024x768 and 60 Hz

A problem you may also have in mind that Knoppix KDE needs about 192 MB of RAM to start with GUI(graphically user interface)

The above posts show you more advanced ways ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
live cd of knoppix roy_anjan Linux - Newbie 8 12-17-2005 02:00 PM
knoppix 3.9 live installer wdavis65 Linux - Newbie 14 09-16-2005 02:11 PM
Knoppix/Other Live CD mhelliwell Linux - Distributions 3 02-28-2005 05:23 AM
Knoppix Live CD akahomeruk Linux - General 4 02-10-2005 04:32 PM
Knoppix/live cd ginge12 Linux - Software 2 11-19-2003 10:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration