LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   kmix resets PCM volume to zero (https://www.linuxquestions.org/questions/linux-software-2/kmix-resets-pcm-volume-to-zero-377803/)

ianio 10-28-2005 01:06 PM

kmix resets PCM volume to zero
 
everytime i load a new audio file into amorak or realplayer there is no sound.
upon checking it seems that with each new track kmix sets my PCM volume slider back to zero. every time i slide it back up and its fine, then a new track starts and its back to zero again.
i am kind of new to linux but since upgrading to openSuse10 (which is great) i wanna stay with it.
please help.

goofytoad 12-04-2005 09:39 PM

Quote:

Originally Posted by ianio
everytime i load a new audio file into amorak or realplayer there is no sound.
upon checking it seems that with each new track kmix sets my PCM volume slider back to zero. every time i slide it back up and its fine, then a new track starts and its back to zero again.
i am kind of new to linux but since upgrading to openSuse10 (which is great) i wanna stay with it.
please help.

I'm in the same situation. :confused:

ianio 01-06-2006 10:04 AM

well i seem to have had some luck on this one. i sorted it last time and then had to reinstall after some major hardware changes. Of course i forgot what i did so had to fluff it all over again.
the trick is to open kmix and edit the settings to read reset levels on boot.
then close it down. set a track playing on amorak and move all the volumes so they are as you want them. its the PCM slider that seems to be affected.
Then when you are happy stop the track playing and then quit amorak.
then shutdown the system and restart.
when its all back up again you can restart amorak and the sound should be there. and remain so even after track changes and system reboots.
if not then you could try switching to the helix engine in amorak and setting the track crossover. this initially worked for me but i still had the same trouble with realplayer.

i hope this is useful.

linsey 03-01-2006 11:13 AM

KMix Problem
 
I have the same problem. I tried what you suggested but with no success. Any more help would be appreciated. Thanks.

grym 03-01-2006 11:32 PM

as root

alsamixer

make your adjustments then

alsactl store

Then get out of root!!

linsey 03-15-2006 06:06 AM

Thanks for the advice. In the end I changed from SuSe 10 to Ubuntu 5.10 and that solved the problem.


All times are GMT -5. The time now is 09:52 PM.