Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-29-2005, 12:05 AM   #1
LQ Newbie
Registered: Jul 2005
Distribution: suse 9.3 pro
Posts: 21

Rep: Reputation: 15
kmix mixer on startup

Hi everytime I log into a kde session the kmix mixer window is always open eventhough I set my window behaviour so that I get a clean session when I log in. I know this sounds trivial but I can't seem to disable it (unless I uninstall it). Does anyone else have this problem and does anyone know how to fix it?
Old 07-29-2005, 09:58 AM   #2
Registered: Jun 2005
Distribution: !<:Slackware:>!
Posts: 99

Rep: Reputation: 15
Question when you login, do you hit exit or minimize?

if you have it in the system tray it'll always start up, but the window should not be up, so I believe you hit exit, and it says like, kmix will continue running in the tray, is this ok, or it might do it automatically. I that's not working let me know.

slackwarebilly : D
Old 07-30-2005, 04:25 AM   #3
LQ Newbie
Registered: Jul 2005
Distribution: suse 9.3 pro
Posts: 21

Original Poster
Rep: Reputation: 15

Yeh, I do press exit and the mixer closes and kmix continues to run in the system tray. But next time I log in, the mixer window will be open again. This happens even if I quit kmix mix altogether, weird huh?
Old 08-03-2005, 08:07 AM   #4
Senior Member
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
KDE Control Center => KDE Components => Session Management.

Which setting do you have for "Login options"?

If it's "restore last session", then you might want to actually kill all instances of KMix using killall -9 kmix (because there's obviously one saved in your session that you cannot see, which is being reopened when you restore the session).

If it's 'Restore manually saved session' (and you have the option to save your session at logout turned on), then maybe you haven't saved your session in a while, and so the only session available to restore is one that had KMix open at the time of logout. So try closing all open instances of KMix (again using killall -9), open a new instance and get it in the tray, logout, login, and see if the problem recurs.

Alternatively, you could set the Startup Options to 'Start with an empty session', logout, and log back in, which will then not reopen any programs that you had open at logout. If that works correctly, then open KMix normally (if it is not already open and in the panel), then go back to kcontrol, and change the startup options back to 'Restore last session', then log out and back in again, which should also solve the issue.

Hope this helps.
Old 08-03-2005, 07:41 PM   #5
LQ Newbie
Registered: Jul 2005
Distribution: suse 9.3 pro
Posts: 21

Original Poster
Rep: Reputation: 15

Thanks for the advice but I've already tried that... I think the problem is I use an ibm laptop which has a plugin for the ibm volume control. This plugin is linked to kmix and thats why it's always open when I start up. Like I said this is no real big problem so I'll just live with it

Thanks anyway


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
KMix window on startup seanr Linux - Software 8 02-26-2008 01:43 AM
KMix Crashing On Startup AFI_Flame Linux - Software 1 10-16-2004 10:57 PM
lost mixer kmix 123racoons Fedora 0 06-24-2004 11:45 AM
Kmix, docked at startup ? fcarli Linux - General 5 11-06-2003 07:58 PM
Problem with sound mixer (KMix) mad_ady Linux - Software 0 11-05-2003 12:24 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:33 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration