LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-11-2009, 11:39 AM   #1
CrashedAgain
Member
 
Registered: Jan 2004
Posts: 307

Rep: Reputation: 33
kmix finding wrong sound card


Stupid problem...about every other time I start up, kmix starts up set to the on-board SiS sound driver instead of the Audigy 2 ZS card, thus there is no sound.
~.kde/share/config/kmixrc seems to be correct:
Code:
AllowDocking=true
Labels=true
MasterMixer=ALSA::Audigy_2_ZS__SB0350_:1
MasterMixerDevice=0
Menubar=true
Orientation=Horizontal
Position=-890,348
Size=1964,365
Tickmarks=true
TrayVolumeControl=true
ValueStyle=Absolute
Visible=false
startkdeRestore=true

[0]
Mixer_Name_Key=SiS SI7012
View.input.Devs=6
View.output.Devs=6
View.switches.Devs=16

[1]
Mixer_Name_Key=Audigy 2 ZS [SB0350]
View.input.Devs=11
View.output.Devs=35
View.switches.Devs=10
so what could be wrong??

(Debian Lenny system)
 
Old 03-11-2009, 02:27 PM   #2
T74marcell
Member
 
Registered: Mar 2009
Posts: 102

Rep: Reputation: 18
Maybe switch the [0] and [1] section contents with each other in the config file, so that Audigy is considered the default (first) entry). I don't know if this works, but it's worth a try.

Arch Linux

Last edited by T74marcell; 03-14-2009 at 01:09 AM.
 
Old 03-11-2009, 02:37 PM   #3
CrashedAgain
Member
 
Registered: Jan 2004
Posts: 307

Original Poster
Rep: Reputation: 33
Already tried that.

Confusing thing is that sometimes it works properly but sometimes not...almost as if it had another config file somewhere.
 
Old 03-11-2009, 04:55 PM   #4
almatic
Member
 
Registered: Mar 2007
Distribution: Debian
Posts: 547

Rep: Reputation: 67
I'd just disable the onboard sound in the bios to save the trouble dealing with 2 soundcards. Or do you need it for anything ?
 
Old 03-11-2009, 05:44 PM   #5
Linuxchuck
LQ Newbie
 
Registered: Aug 2007
Distribution: Slackware from 94-09, Debian Since March 09
Posts: 28

Rep: Reputation: 19
Give this a shot:

Open /etc/modprobe.d/alsa-base with a text editor of your choice and scroll to the end.

append the following lines to the end of it:

Code:
options snd-emu10k1 index=0
options snd-intel8x0 index=1
Please note that I do not know for certain what driver you are loading for your SIS7012 card. I made a presumption that it would be the intel8x0 driver. If that is not correct, then just substitute the appropriate module name where I put "intel8x0".

This should force your audigy to become the "primary" card at every reboot, and the onboard SiS card to become the "secondary". If you want it the other way around, just swap the 1 and the 0.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help finding a sound card fakie_flip Linux - Hardware 1 09-29-2008 06:43 PM
alsaconf not finding sound card stevemalcolm Debian 1 09-22-2005 02:01 AM
Wrong Sound Card jrcreasy Debian 7 08-20-2005 12:07 PM
Need help finding a sound card driver (ES1869) calimer Linux - Hardware 3 04-23-2003 01:16 PM
SB Live (Value), KMix and sound-card identification... Thymox Linux - General 3 02-01-2002 11:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration