LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 10-29-2008, 12:38 AM   #1
suse91pro
Member
 
Registered: Sep 2004
Distribution: Primary: Windows XP Home Edition SP3/Secondary: Ubuntu 9.10 (Gnome)
Posts: 98

Rep: Reputation: 15
KlamAV Anti-Virus Manager Update error?


I install KlamAV Anti-Virus Manager For The KDE Desktop and clamAV Anti-Virus from YaST -> Software -> Software Management i updated the ClamAV virus database. after that i i got popup message said Download and inmstall Klamav 0.44 : It looks lie your version of Klamav is out od date KlamAv 0.44 is the most recent version avaliable.Would you like Klaman to download and compile it for you?

I have 2 options download and install KlamAV 0.44 or cancel so i go for option 1.

When i get this message :

Pop up message

Compile Klamav - Klamav

You seem to have downloaded klamav-0.44 already (in /home/John/klamav/klamav-0.44) Would you like to skip re-downloading it and just try to compile it? Again o have 2 options yes or no i press yes.

The next popup say :

Instal Klamav-0.44- KlamavKlamav 0.44 is ready to compiling and installation. Would you like the wizard to as you for the root password so it can be compile and install it for you? If not you can compileit yourself later at
home/John/klamav/klamav-0.44)

So i have again 2 options use the wizard or cancel i choose the first option


When i get this popup message :

I press ok

Compilation Tips -Klamav

If this is your first time youve compiled software then here are a few useful tips:

1. Any errors messsages in the log flie with the words "KDE" `curl` or `X` in them mean that you need to install the appropriate development libraries.

2. Any package provided by your distribution with lib or devel in the name is development library e.g qt-devel, libkde.

3. if you encounter errors installing dazuko, just deselect it at installation time and try the instructions at www.dazuko.org

4. Some distributions provide a dazuko package. see if yours does.


THe installation program popup installing Klamav i press next it says in an error accured so press view log flie



***** Klamav
***** Running configure (./configure)...
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... no
checking for kde-config... /opt/kde3/bin/kde-config
checking where to install... /opt/kde3 (as returned by kde-config)
checking for style of include used by make... none
checking for gcc... no
checking for cc... no
checking for cl.exe... no
* configure: error: no acceptable C compiler found in $PATH
* See `config.log' for more details.
***** Return value 1

Last edited by suse91pro; 10-29-2008 at 01:41 AM.
 
Old 10-29-2008, 01:35 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,772

Rep: Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294
Quote:
* configure: error: no acceptable C compiler found in $PATH
That means that you either don't have gcc installed, or (more unlikely) it's not in your path.
 
Old 10-29-2008, 01:40 AM   #3
suse91pro
Member
 
Registered: Sep 2004
Distribution: Primary: Windows XP Home Edition SP3/Secondary: Ubuntu 9.10 (Gnome)
Posts: 98

Original Poster
Rep: Reputation: 15
Ok what should i do to fix that error?

There also another stange thing and that is there is 3 icon for KLamAV in the tray why?
 
Old 10-29-2008, 02:37 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,772

Rep: Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294
Use Yast to install gcc and its dependencies. Also check if there is already a newer Klamav package, so you'll not have to compile it.

Regards
 
Old 10-31-2008, 07:18 PM   #5
suse91pro
Member
 
Registered: Sep 2004
Distribution: Primary: Windows XP Home Edition SP3/Secondary: Ubuntu 9.10 (Gnome)
Posts: 98

Original Poster
Rep: Reputation: 15
Now i have install all gcc files i cot find except a few that was to old. But klamav still popup with message download and instal Klamav 0.44, i search after an update klamav but there no update.

As i see i have choose find out the path for Klamav or uninstal it and all gcc`s?
.
 
Old 11-01-2008, 08:03 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,772

Rep: Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294
You can get the Suse package from here.
If you use a 64bit OS select the appropriate package for your architecture.

Regards
 
Old 11-05-2008, 06:44 AM   #7
suse91pro
Member
 
Registered: Sep 2004
Distribution: Primary: Windows XP Home Edition SP3/Secondary: Ubuntu 9.10 (Gnome)
Posts: 98

Original Poster
Rep: Reputation: 15
I downloaded the RPM file and i try to install it Klamav to version 0.44 first with software installer and when direct in yast but error is one below the next is yast is that libclamav.so.4 is needed but there is no there is no libclamav.so.4(CLAM_PUBLIC) and libclamav.so.4 for opensuse 11

Should i just uninstal klamav and all the lib files?




I got this error message:

Yast 2

Error

The package /home/username/Documents/klamav-0.44-11-11.1.i586 cot not be install.

detailes :

Subprocess failed. Error: RPM failed : warning :

/home/username/Documents/klamav-0.44-11-11.1.i586 : header V3 DSA sdiganatur : NOKEY, Key ID d8fcde21
error: failed dependencies :

libclamav.so.4 is needed by clamav.044.-11.1.i586

libclamav.so.4(CLAM_PUBLIC) is needed by klamav-0.44-11.1.i586
 
Old 11-05-2008, 07:26 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,772

Rep: Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294
According to the dependencies you need also clamav-lib and because clamav-lib depends on clamav-data, you'll also need that too.
So you should install clamav-data, clamav-lib and then at the end Klamav.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Microsoft Anti-Spyware Deleting Norton Anti-Virus LXer Syndicated Linux News 0 02-13-2006 04:31 AM
Klamav - virus found - Zip.ExceededFilesLimit rrsc16954 Mandriva 7 01-16-2006 06:53 PM
Kaspersky Anti-Virus for Linux File Server: Can't find license manager azmadar Linux - Security 1 12-02-2004 08:29 AM
Boot virus or Anti-Virus? AVG Free Anti-Virus Software problems SparceMatrix Linux - Security 9 08-02-2004 02:35 PM
Creating an ultimate anti-virus and anti-spam email gateway markcc Linux - Networking 2 10-08-2003 03:10 AM


All times are GMT -5. The time now is 03:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration