-   Linux - Software (
-   -   kile installation (

hari78 03-13-2005 07:13 AM

kile installation(solved)
while installing kile 1.7.1, i get the follwing error message
configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix

any one, please instruct on what to do
thanks in advance

__J 03-13-2005 07:19 AM


what prefix are you trying to install to and do you have kde headers on your system?

hari78 03-13-2005 07:24 AM

i am sorry. i am so new to linux that i am not able to answer your question. plz explain what is a prefix and how to know whether kde headers are installed or not

__J 03-13-2005 07:33 AM

prefix is where the root of the installation will be installed. so for example if kde is installed to a prefix of /opt/kde, then binary executables will end up in /opt/kde/bin, libraries in /opt/kde/lib, headers (include files) in /opt/kde/include, etc..

By default, if you just do ./configure with no arguments:

make install

the prefix will be /usr/local. you can change the prefix like:

./configure --prefix=/opt/kde

On to your header problem, with an rpm distro you have to keep in mind they split their packages into different parts. You probably have something like kdebase-3.3.2-i486.mdk.rpm installed for kde. There is probably a package named kdebase-3.3.2-devel-i486xxxxx that has the includes you need to compile against the kde libraries. either use urpmi or rpmdrake ( remember these need to be run as root) to install the -devel packages for kde, then redo your configure with the prefix of the kde installation ( usually /opt/kde or something similar).

hari78 03-13-2005 08:02 AM

thanks a lot for your detailed reply. after installing kdebase, it works fine now

junhy 12-13-2006 04:35 AM

Hi people. I'm a newbie in Linux and I barely know how it works. Since I am a Latex and Winedt user I tried to install Kile on my Kubuntu installation. Too much problems for the moment in the installation cause I got the error for compiling. In concrete the error is that the libstdcc++-dev file is not installed but apparently I checked all the packages and all of them are perfect. Moreover, since I don't know how to use Linux I don't know if I have to install manually such files. Does anybody know any solution? I'm getting frustrated.

All times are GMT -5. The time now is 07:16 PM.