LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   keyboard wierdness after upgrade. (https://www.linuxquestions.org/questions/linux-software-2/keyboard-wierdness-after-upgrade-296157/)

spiritwing 03-01-2005 03:38 AM

keyboard wierdness after upgrade.
 
Hi All,

I recently upgraded my machine and I am having a bit of trouble with the keyboard. I have spent hours with google and man pages to no avail. Here is a description of the problem:

If I hit the single quote key: Nothing happens
if I hit the single quote key twice in a row I get: ī
if I hit the single quote key followed by the space bar I get: '

If I hit the double quote key: Nothing happens
if I hit the double quote key twice in a row I get: Ļ
if I hit the double quote key followed by the space bar I get: "

I need to hit the following keys twice to get a character: ~ ` ^

This only happens in KDE. When in text mode, or using any other window maker besides KDE the keyboard behaves correctly. This issue is driving me nuts, if you can help it would be greatly appreciated.

Cheers,
Silas

=0)

spiritwing 03-01-2005 03:49 AM

There are some darned helpful people hanging out on #kde on freenode. Here is the disscusion that led to the fix.

silasb I have a question that will probably turn out to be something silly... please see http://www.linuxquestions.org/questi...hreadid=296157

PhilRod it's too early in the morning in Europe - everyone here's still asleep (or brushing their teeth getting ready to go to work) :-)

canllaith ok

canllaith it looks like you have the keybaord layout

canllaith us intl with deadkeys

canllaith silasb: so check Kcontrol -> Regional & Acessibility -> Keyboard Layout

canllaith silasb: and see what it says under Active Layouts

canllaith You probably have U.S. English w/ deadkeys enabld

canllaith and you'll want something more like U.S. English (or another variant)

xzz Dead keys. o_O

silasb I donīt see anything about dead keys under Kcontrol -> Regional & Acessibility -> Keyboard Layout

silasb the layout is set to u.s. English

silasb Oh I see down in the Command: text box there is a -variant flag set to intl

silasb changing that option to alt-intl fixed it

silasb canllaith: Thank you so much!!! ;0)


All times are GMT -5. The time now is 04:15 AM.