LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-13-2014, 12:50 PM   #1
nyuwa43
LQ Newbie
 
Registered: Jun 2009
Location: Japan, Hayama
Distribution: Mint 17, Cinnamon / Lubuntu 14.04
Posts: 17

Rep: Reputation: 0
Keyboard editor


Good evening
Very long ago I used WordPerfect. That had a keyboard editor built in, allowing to assign individual keys differently.
Later I had to use a (not very elegant but still working) MS application to achieve that.
Achieve: I use English + German keyboard layouts.
But since I am used to the English KB layout, I would like to reassign the "z" and "y" keys, which are on these two KB layouts reversed.

Is there somewhere a little application out there, that lets me do that?
I have been looking but cannot find anything.

Thank you in advance.
 
Old 08-13-2014, 02:48 PM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: Fedora 34
Posts: 3,693

Rep: Reputation: 1075Reputation: 1075Reputation: 1075Reputation: 1075Reputation: 1075Reputation: 1075Reputation: 1075Reputation: 1075
You should be able to use the command setxkbmap to set a standard layout, or xmodmap to do low-level tinkering.
 
Old 08-13-2014, 08:44 PM   #3
nyuwa43
LQ Newbie
 
Registered: Jun 2009
Location: Japan, Hayama
Distribution: Mint 17, Cinnamon / Lubuntu 14.04
Posts: 17

Original Poster
Rep: Reputation: 0
Thank you!
I will have to study about that.
Being anything but a computer expert the terms "setxkbmap", "xmodmap" mean precisely nothing to me,
so that I have absolutely no idea what to do and how to do it ...
 
Old 08-14-2014, 01:04 PM   #4
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,862

Rep: Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166
The German keyboard layout is /usr/share/X11/xkb/symbols/de and it contains the lines
key <AD06> { [ z, Z, leftarrow, yen ]};
key <AB01> { [ y, Y, guillemotright, U203A ] };
If you swap over the "y" and the "z", that will give you qwerty instead of quertz the next time you log in. You have to repeat the trick when you re-install a new version of Linux, but it's a lot less trouble than learning and using xmodmap.

PS You need to run a terminal and become root with "su", then launch your editor; or else use "sudo name_of_editor" — it depends on your distro. That's why it's a good idea to put your distro name in your profile.

Last edited by DavidMcCann; 08-14-2014 at 01:07 PM. Reason: addition
 
Old 08-17-2014, 10:17 AM   #5
nyuwa43
LQ Newbie
 
Registered: Jun 2009
Location: Japan, Hayama
Distribution: Mint 17, Cinnamon / Lubuntu 14.04
Posts: 17

Original Poster
Rep: Reputation: 0
Thank you, but

Thank you!
That sounds like a really "workable" option.
However, even though I am the one and only user, set my account to "administrator",
running a terminal -> enter "su" + PW ...
I get the error "Authentication failure".
There is only one password that I set, there is only one account.
How can "authentication" fail?

And attempts at changing the permissions for the "de" file in order to make changes also failed.
Probably I made mistakes, but do not know where.

PS: Thank you for your hint about my profile.
Actually, I set up this account but used it only once several years ago.
My struggles to get friendly with Linux remain(ed) mostly futile, so I did not bother about setting up a fancy profile.
But today I added a few lines ...
 
Old 08-17-2014, 11:47 AM   #6
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,862

Rep: Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166
That's because you're using Mint and Lubuntu, which don't use an administrative password. You need to type
sudo gedit /usr/share/X11/xkb/symbols/de
and then it will prompt for a password and you type the one that you used to log in.
 
Old 08-24-2014, 10:37 AM   #7
nyuwa43
LQ Newbie
 
Registered: Jun 2009
Location: Japan, Hayama
Distribution: Mint 17, Cinnamon / Lubuntu 14.04
Posts: 17

Original Poster
Rep: Reputation: 0
I am really sorry to bother you, but ...
I still cannot make it work.

Thanks to you, I WAS able to edit the file. VERY good so far.
The original file, as you pointed out, looked like:
The German keyboard layout is /usr/share/X11/xkb/symbols/de and it contains the lines
key <AD06> { [ z, Z, leftarrow, yen ]};
key <AB01> { [ y, Y, guillemotright, U203A ] };

After my editing (copied from that file) it looks now like:
key <AD06> { [ y, Y, leftarrow, yen ] };
key <AB01> { [ z, Z, guillemotright, U203A ] };

(rebooted / restarted)

Yet, I still get the original configuration, where in the German KB layout z + y are reversed.
Did I make another mistake?
Or do I have to change THE OTHER instances (plural) of "z + y" occuring in the file?
(some look very scary to me)

Somewhere in the middle of the file it also says:
partial alphanumeric_keys
xkb_symbols "qwerty" {

// This layout should work exactly as a de with the exception
// of 'Z' and 'Y' keys, which are in the qwerty style (ie. swapped).
// 2008 by Matej Košík <kosik@fiit.stuba.sk>

include "de(basic)"

Does this mean, the original keyboard layout was SUPPOSED to work like a qerty KB? (it did not, though)

I appreciate your help.
 
Old 08-24-2014, 11:52 AM   #8
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,862

Rep: Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166Reputation: 2166
Looking at the file, I see that there are lots of variants — 15 on my computer. My fix was for the first on the list, and you must have one of the others installed. But it turns out that you don't need to edit anything. The item you found is a driver for a German QWERTY keyboard, which I didn't know existed. Run the keyboard configuration tool. Delete the German driver you have. Then add a German keyboard, selecting QWERTY from the variants offered. That will sort it out.

Last edited by DavidMcCann; 08-24-2014 at 11:54 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] return text from geany or other editor to IDE after saving and closing the editor mtdew3q Programming 4 05-15-2013 11:40 PM
LQ is Looking for a News Editor and a Content Editor jeremy Linux - News 7 05-19-2012 12:58 AM
linux distro / photo editor / music editor of choice ?? expatcanuck Linux - Newbie 1 05-04-2009 06:24 PM
LXer: Open Movie Editor: Linux Video Editor with Plot Twists LXer Syndicated Linux News 0 10-27-2008 10:50 PM
CLI editor with standard M$ keyboard shortcuts cuboidz Linux - Software 4 11-04-2003 08:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration